Hi Guys,

I was trying to setup a Logitech Attack3 joystick for manual control of my APM running the latest ArduPlane 2.4 firmware.

I'd like to mention that I have NO R/C system connected to the APM (I don't even own one). Perhaps this is the problem. If it is so, I think you guys might be able to provide me with a solution with the below problem.

I opened Mission Planner after attaching the joystick and opened the joystick panel. After setting it up, all the axes worked perfectly. I had previously calibrated the joystick in Windows.

But, when I connect to the APM via through Xbee @ 57600 baud, the joystick control stops working. The values in the panel revert and freeze. No joystick inputs are taken. APM status tab shows all the R/C override channels to be permanently set at 1500 PWM. Tried via USB and same problem.

One important thing here, the buttons keep working even after connecting, probebly because they are not overriding the R/C channels.

I have to close and reopen Mission Planner to get joystick functions back, but only till the APM is not connected.

Please HELP!!


Views: 8145

Reply to This

Replies to This Discussion

and strange as it sounds, the problem is only with the elevator stick!!


I'm new to a lot of this stuff, and I'm trying to do joystick control as well and ran into the same problem. Maybe this is a dumb question but I couldn't figure it out.

Where is system.pde, and how do I modify it?


expo is off (0) for each one and actually grayed out for throttle.

Good day, I have Genius joystick connected to Mission Planner 1.3.7, every thing is working as I expect. But when I connect the Ardupilot 3.1.0 via the MAV link, the joystick not responding anymore. To recover the joystick I need to restart the Mission Planner.

I also recompiled the Apdupilot, commented out the trim_radio() in system.pde and added the definitions at the top of this file like

# define RC1_MIN = 1000  

# define RC1_MAX = 2000


and so on for first 4 channels. But this gives nothing so I am not sure I am doing the right way the modification of sources. Could you guys give me some clues? Many thanks! 

P.S. I am not sure how, but one time I have done the Radio Calibration with the Joystick, but now I cant open the Radio Calibration without connecting the Ardupilot to Mission Planner, so joystck becomes anavalible everytime.  


Is there a guide maybe, where a joystick configuration is presented? ( MP setup for no RC use)


How important is commenting out the trim_radio() part of the code? I have over 50 successful flights on both fixed wings and multirotors using joystick control. (no R/C on board at all). I have set the Min, Max and Center to the right numbers, and the center (trim) does not change after reboot. What would make the center (trim) value change during flight anyways?


I'm trying to use the joystick but it still doesn't work. Have you done any modification to the code to make it work?


I use joystick with success without any code modifications. Just some tuning of the ardupilot parameters

No if you connect to the APM by any way, then go to the Config/Tuning tab the Full Parameter List and scroll down till you find which parameter you want to change. You can also search by a search text box somewhere in the right column. After you change any parameter it will turn green. If you want to save your parameter press write parameters which will save the parameters on your APM

I'm looking at this for guidance on joystick control, you might be interested.


Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service