Hi Guys,

I was trying to setup a Logitech Attack3 joystick for manual control of my APM running the latest ArduPlane 2.4 firmware.

I'd like to mention that I have NO R/C system connected to the APM (I don't even own one). Perhaps this is the problem. If it is so, I think you guys might be able to provide me with a solution with the below problem.

I opened Mission Planner after attaching the joystick and opened the joystick panel. After setting it up, all the axes worked perfectly. I had previously calibrated the joystick in Windows.

But, when I connect to the APM via through Xbee @ 57600 baud, the joystick control stops working. The values in the panel revert and freeze. No joystick inputs are taken. APM status tab shows all the R/C override channels to be permanently set at 1500 PWM. Tried via USB and same problem.

One important thing here, the buttons keep working even after connecting, probebly because they are not overriding the R/C channels.

I have to close and reopen Mission Planner to get joystick functions back, but only till the APM is not connected.

Please HELP!!


Views: 8145

Reply to This

Replies to This Discussion

to use it without a transmitter you will need to override a few things. mainly the radio trim


in system.pde line 320

trim_radio(); needs to be removed so the trim center point dont change each reboot.


you will also need to manual put start and end point on all the first 4 radio channels.

RC1_MIN = 1000

RC1_MAX = 2000

RC1_TRIM = 1500

NOTE you can overdrive servos if your not carefull with these values 

if you do that for all channels you should be able to control it using the joystick without any rc.

Thanks Micheal,

I'll do a recompile of the latest ArduPlane with those modifications when I get back home!


Were you able to get it working without a R/C? I have only a joystick and do not even own a radio either. I have the same problem as you.

Is this the correct way to set up the APM 1 for joystick control only? My RC isn't great anymore and i would like to swap over to just using the joystick but didn't know how to do it.

Do you just edit the code in the arduino interface?


Thanks for the quick reply. I'm getting rid of my rc and I am going to try to get 10km from the 3DR radio's i seen somewhere that they have already got 7.6km+

If I reduce the telemetry refresh will this slow down the tracking on my Antenna tracker? 

Thanks for all the help again 


Thanks for all the help, I'll buy all the bits this week and report back in a next weekend to see if the setup works :-)

Just an update for you guys, Joystick control works perfectly with Micheal's mods in the code.

A problem that I seem to have, even after calibrating the joystick in windows and in MP via Radio Calibration, there seems to some dead zone around the servos. I manually set the dead zone to 1 on all the channels, but if 1 elevon channel gets fixed, the other gets messed up.

In auto mode, the elevons are in their mean position, but switching to manual (joystick) deflects any one elevon by 8 - 9 degrees.

Setting all the MAX-MIN value to 2000-1000 and trim to 1500 results in the same problem. This is a recent problem, and had not happened before. 

Would appreciate any help on this.

check expo in the joystick option is turned off ie 0

I have edited the code in the arduino IDE but it will not upload. I deleted "trim_radio()" and put

"RC1_MIN = 1000

RC1_MAX = 2000

RC1_TRIM = 1500"

For channels 1 to 4 in its place. Is there a way of getting the APM Planner upload the edited code with the minor change or do I have to use the Arduino IDE?

Is it then placed in the APM planner? Sorry for all the Qs never really edited the code before. Never went well in the past lol. Thanks again for all the help :)

where do i find the 

"RC1_MIN = 1000

RC1_MAX = 2000

RC1_TRIM = 1500" in the code? Or do i have to just copy and paste it in somewhere for RC1 to RC4. Thanks for all the help. :) 

Has there been any update on this? I am having a very similar issue.

I have an Xbox 360 controller, and a 3DR radio. I do own a RC transmitter though.

The issue is similar though: the joystick shows full range on all axes, but when I connect via 3DR radio or USB the range is greatly reduced (eg, roll: 1452-1504) on some axes (not all, and it seems to be random). RC control does not seem to be able to override it.

I've tried this on multiple computers as well.

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service