I'm trying to run ArduPlane in SITL on a native debian based Linux system (Ubuntu 16.04)
In ArduCopter everything is working fine.
I followed the very good tutorial in http://ardupilot.org/dev/docs/setting-up-sitl-on-linux.html
However the intended when I run ~/ardupilot/Arduplane/sim_vehicle.py -w I get the "newer version of JSBSim"
I followed the turtorial to update jsbsim, but it say it is already the latest version.

See the terminal log :

maarten@maarten-PC:~/ardupilot/ArduPlane$ sim_vehicle.py -w
SIM_VEHICLE: Start
SIM_VEHICLE: Get JSBSim version

SIM_VEHICLE: "JSBSim" "--version"

=========================================================

You need the latest ArduPilot version of JSBSim installed
and in your \$PATH


Please get it from git://github.com/tridge/jsbsim.git
 See

http://ardupilot.org/dev/docs/setting-up-sitl-on-linux.html

for more details
=========================================================


SIM_VEHICLE: Killing tasks


maarten@maarten-PC:~/ardupilot/ArduPlane$ cd ~/jsbsim

maarten@maarten-PC:~/jsbsim$ git pull

Already up-to-date.

maarten@maarten-PC:~/jsbsim$ ./autogen.sh
--enable-libraries

**Error**: You must have `libtool' installed to compile jsbsim.

Get ftp://ftp.gnu.org/pub/gnu/libtool-1.2d.tar.gz
(or a newer version if it is available)

maarten@maarten-PC:~/jsbsim$ cd ~

maarten@maarten-PC:~$ sudo apt-get install libtool automake autoconf libexpat1-dev

Reading package lists... Done

Building dependency tree      

Reading state information... Done

autoconf is already the newest version (2.69-9).

automake is already the newest version (1:1.15-4ubuntu1).

libtool is already the newest version (2.4.6-0.1).

libexpat1-dev is already the newest version (2.1.0-7ubuntu0.16.04.2).
0 upgraded, 0 newly installed, 0
to remove and 5 not upgraded.
N: Ignoring file '50unattended-upgrades.ucf-dist' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension
maarten@maarten-PC:~$

Views: 902

Reply to This

Replies to This Discussion

SOLVED

The libtool needed an installation with -bin option

Hej Maarten,

today I ran into the same problem. Could you explain the solution in more detail? I tried to research but could not figure out the solution.

Kind regards,

Sebastian

I have the same problem, and I do these steps then it's solved, works for APM code version arduplane-3.7.1

Open the Cygwin Terminal, navigate to your home directory, and enter:
git clone git://github.com/tridge/jsbsim.git
cd jsbsim
./autogen.sh
make
cp src/JSBSim.exe /usr/local/bin



Seb said:

Hej Maarten,

today I ran into the same problem. Could you explain the solution in more detail? I tried to research but could not figure out the solution.

Kind regards,

Sebastian

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service