Learner Plates Warning - connecting Mavlink fails - Got param VOLT_DIVIDER

Hi Peeps,

I just got a AMP2.5 to play with, hoping to use it for several projects such as a camera gimbal controller, a multicopter and possible use it in a plane and boat too :)

I managed to connect over USB only and set it up for a quad firmware, I could see the GPS and attitude change. 

I had a quick play connecting a servo, but I think the servo drew too much current from the USB so it browned out.

This morning I tried to connect a 4cell nimh battery with J1 removed and it hasn't been happy since.

The board powers in USB only mode, the virtual com is visible windows device mangler, It will connect in terminal mode and responds, although I don;t know how to use that in a useful way yet.

When I connect in anyother mode it opens the connecting mavlink window, after about 26 on the countdown it flashes past a couple of things and then sticks saying "got param VOLT_DIVIDER" and then fails.

I have googled this but can't see anyone who has has had the same thing.

Can any one help please?



Views: 543

Replies are closed for this discussion.

Replies to This Discussion

further playing...it seems I can reflash the firware now....but it seems to get stuck on connecting at different points before and after. So it seems like a comms issue? I am going to try with my old XP laptop and see if that helps.

Hi, 6 volts is too much for the APM. It might have survived it, just be aware that there is no onboard voltage regulator and its really designed for only 5 volts.
Try connect with CTRL-T from the planner and see if the sensors are still alive. The failure to connect the regular way still needs to be solved though, fortunately th, at cant really have been bc of the voltage overload. Yes do try w a different computer.

Regards, Soren

Hi Soren,

I looked at the voltage limits already, the battery has 5.2V on it. Will do, still working on getting my old pc set up, it's not playing nice :).


OK, got other PC up, and its the same issue, stops at VOLT_DIVIDER,

Using terminal to check the sensors:


Compass OK

altitude doesn't seem to be...just stays at 0cm.

ins doesn't seem to work, but is that for an add on module?


That's correct. Over 6V is too much, but if powering from the Outputs side the protection zenner diode will limit the voltage to 6V (this saved my board when i accidentally knocked the voltage on my Lab power supply to more than 6V) @Stuart, where did you connect the battery to the board? Was it through a regulator or BEC?

Hi Bill,

I used one of the outputs, I cant remember which. it was direct, but the battery isn't over 6V though, its 5.2V.

How is the altitude supposed to act in terminal mode? when I move the unit up it stays at 0cm, I assume this is supposed to change from the start point?



What's the battery voltage when connected to the APM when its under load? Freshly charged NiMH are 1.45 Volts, so you would see 5.8V down to 4V when they have expelled all their energy. 4.5V is the minimum stated voltage to power the APM, 4.8V is probably a more realistic working low voltage. YMMV.

Personally, I would recommend using a battery only via a regulator i.e.. a 6S NiMH (7.2V), or 2cell LiPO (7.4v) regulated to 5V via a BEC. The reason is that you get less problems with the voltage dropping from the required 5V to the APM as the batteries energy is used up.

That was the plan long term. For bench testing I used a measured 5.2v battery.

Hi chaps,

I have searched but can't find an answer to if its ok to use my APM power module at the same time as with usb plugged in at the same time....before I damage another board :).

I am not connecting anything else at the moment, but the jumper will be removed before I power the output side with a bec,

Cheers in advance.



© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service