Wassup people,

Is there anybody out there who would be kind enough help me analyse my latest flight log that ended in a crash?

In the past i (since a year) have had good sucsess with my APM2 mounted in a standard rcexplorer tricopter. Any hickups in the past have been sorted with a suitably timed software update. 

The latest code 2.7.3 has been brilliant for me especially with my newly flashed esc's. I have been experimenting with auto mode and waypoint missions with good success. Im using the standard gps.

This flight, I was watching the auto mission unfold via fpv. The waypoints were successfully (for me)achieved (apart from the last one, which i believe is a known issue) and the tri was in a hover after the last waypoint. As far as i can remember i switched to stabilize and took control for a few seconds then decided to switch back into auto and run the route again. (like i have done in the past, although not quite as quickly). I watched as the tri violently banked to the right and started loosing altitude, not going in the direction of the first waypoint. I let it go as long as i dared (too long as it turned out) until i switched back to stabilize to take control. There seemed to be a delay in me being able to take control, by which time i fumbled an unscheduled crash landing. 

My current technique of log analysing consists of staring at different graphs that i assume somewhere will explain a fault, but where is the question!

Ive added all the log files that ive got of the flight (probably twich as ive just seen the attatch files tab below also). Ive also got gopro footage if someone thinks it may be helpfull.

Thanks

Alex

2012-09-20%2010-35%204.log

2012-09-20%2010-35%204.log.gpx

2012-09-20%2010-35%204.kmz

Views: 567

Attachments:

Reply to This

Replies to This Discussion

I have asked the dev team to have a look at your logs but I also highly recommend Dan Gray's log visualizer

http://diydrones.com/forum/topics/version-1-3-of-apmlogvisualizer-w...

Hi Alex,
I had a look at your log using APMLogVisualizer version 1.34L, and found that in all probability, a motor failed OR your battery was low enough for one of the ESC's to shut down, OR less likely, one more possibility, your gyro failed in some way.

I suggest that you start logging your motors, you can do this with the CLI using Mission Planner. It would be easier to see what's going on.

I found that during your last auto run restart, your Yaw was pointing to the first waypoint like it should. I see that your pitch is pitched down, toward the waypoint like it should be. The problem is the roll is way off, I mean way off.

You don't happen to have an FPV video do you? in that case, I can compare the video to see if the roll is doing what the sensors say, and if so, we narrow it down to motors/ESC/battery.

Your servo output (RC3ServoOut) was maxed out at 800. When you went to stabilize, you had the throttle all the way up, and the copter was still was falling. The RC3ServoOut was still maxed out when you went to stabilize. It stayed maxed out until you brought the throttle down (I assume at crash time). This means that the APM2 was TRYING to keep the copter in the air, it just couldn't.

So to summarize, most likely, motor 1 or motor 4 failed in some way, probably motor 1.
Less likely, your gyro or gyro software failed in some way.

Dan Gray

You genius Dan. I download my gopro footage today and low and behold if the volume is right up you can hear the motor pulsing as its going in. I rebuilt the craft and you're right I have a problem with either the right side esc or motor, don't know which just yet. Thanks for your diagnosis. I will get on with learning your software, I watched the YouTube vid and it looks brilliant.
Cheers
Alex

Dan, I tried using APMLV from your site by the link in Craig's reference above... http://siderealtechnology.com/APMLogVisualizer1.3.zip

Is that the 1.34L version?

-=Doug

Nice analysis again Dan!

Is there any reason why Motors are not logged by default?

Is it possible to get logging for the Input channels too? I don't see why it wouldn't be. It. Be easy to forget what you did when trying to recover from a crash and having logging of the Inputs would help to find more bugs with the software because less issues will be automatically written off as user error.

Thanks Dan!

Hi Dan, I found the problem. one of the connections to my motor (soldered) had snapped inside the heat shrink, hence the reason i heard it pulsing, it was missing a phase. What is interesting to me is that it is was the motor on the opposite side to which it fell. The APM must have all but stopped the right hand (tricopter) motor when the left one packed up, to try and keep it level. You may have already sussed that one because you did mention that you thought it could be motor 1 or 4! Thought that was pretty cool though.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service