LOG file view needed // X-8 Survey mission // disturbance due to limited motors?

Dear members,

with my octo (X8 frame; APM and MP on latest stable version) i did a survey mission some days ago and had two "instability issues" in the middle of the flight (on a part of the mission when the flight path was just straight on flying).

There was very less wind this day. The Copter got instable, yaw seemed to got in trouble and it startet to loose height and gained height again. I returned to PosHold and stopped (see LOG). Everything was fine and i continued the mission. At the end of the mission the same happened again. I again switched to PosHold and landed safely.



My assumption is that i choose too much ground speed for the mission (5m/s), because of the area i wanted to cover and the batteries i chose a higher speed than the Copter properly could handle. With no reserve for balance and stability corrections it got into trouble.

Could this be a reason?
Thanks in advance for your help.



Please find the LOGs (29MB) here: http://www.filedropper.com/2016-04-2210-08-49


 Alex

Views: 302

Reply to This

Replies to This Discussion

Syrphus:

first problem that I notice is that your copter can't follow well, desire attitude vs real attitude, that's mean that the hardware can't be able to do exact what the controller is saying to do, frame can be be one problem, more probably some motors reaching max throttle and the controller loosing control or a combine but I'm not shure the exact problem, if anyother can help too please?

Look that 210 and 340 for ex, your copter loose complety the control and the resto of flight isn't looks good too, looks here what is desirable http://ardupilot.org/copter/docs/ac_rollpitchtuning.html looks the video and compare with this graphs 

 did you try Autotune?

Hello Cala,

thanks for your quick response.

AutoTune was done (all axis) not long ago and did look fine. Very easy to do and very nice flying performance manually. The Copter should nevertheless be limited to a max. ground speed of 3m/s.

When i did the survey i choose 5m/s and the general limitation might have been overwritten by the flightplan.

Could it be that 5m/s just is too much for my setting and there's no buffer left for reaction and balancing?

Thanks so far

Syrphus

A test that I think you can do, is to fly in pos hold, some time slow and sometime fast on the same fly and compare your log to see if that the problem.
Another thing I'm thinking: that mission was with the gimbal? If you try with and without gimbal what happens? (only ideas to try)

5/m/s don't sound too much for a copter, I reached 11/m/s grnd speed with my slow copter flying FPV , my average speed at pos hold is 15-20 kms/hora FPV; (I fly without gimbal, I'm not shure if can be a problem in higher speeds, probably others with more experience with gimbals can clarificate it)

Todays Mission was with 3m/s only. 
ATTs look better from my point of view.

What do you think?

http://www.filedropper.com/2016-04-2814-53-17

Thanks 

Alex

Dear community,

unfortunately there was a crash in the middle of todays second flight when in a preplanned mission the copter was lost at Alt 80m.

The EKF showed no perfect compass values (also after new calibration on site). Vibs were fine.

After passing a waypoint in HeadingHold and before taking the next survey line the copter just fell.

There might be most of the parts still usable after repair, but i want to sort out the (maybe) critical ones which led to the crash. Maybe we need to change the whole setup.

Thanks for supporting!  :/

Alex

Attachments:

Syrphus: In your two last logs you still have track issues, try not to fly auto and high until you solve it or your copter is in risck because it have difficult to follow what controller was telling to do.

I hope that you have some kind of mechanical issue because any err reports your controller; check your motors and esc if they are working well, try to calibrate your esc again, and check logs flying at low altitude in pos hold near you until you solve it, better remove your gimbal until you solve it. Any other suggestions are welcome too, I'm not complety shure about your issue.

You need something like this

Hey Cala,
thanks again for your support.

Unfortunately there is nothing left for flight tests right now. The crash was to big and a lot of repairs have to be done. I also decided to switch to a conventional octo-design and build up a new version using some of the old parts.

But with the help of the community here i first want to find out about the reason for the crash.
I do not want to use the components unless i am sure they are ok. 
And i do not want to run into the same mistakes in building or failures in flying again....

:(

Thanks
Alex

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service