I am quite new to the arducopter project.   I have flown traditional helis for 15 yrs so have a grasp of rc.

I have built an arducopter to carry my AP camera.

I am quite disapointed with the general stability of it .I have the uprated motors from J drones 30a esc's 12" props. GPS, sonar, mag

I am not trying to carry a camera yet !

I am fully updated on the APM and mission planner. I re-set everthing after updating Running standard PID s and settings

My main problem is when I select alt hold at 1 meter it is OK for a bit then it climbs and does not stop !

If I select alt hold at 6m it climbs straight away and does not stop, when loiter is selected the copter hesitates for 3 seconds then tips about 30 degrees and is off! I have to go back to stabilise a bit quick!

The other problem is when in stabilise it is OK if a little nervous but then it occationally angles over and crashes with no control, but not the same as it did when I lost a motor on two different occations.

I also crashed when it just tipped from about 3 feet having lost lift on one motor due to an esc failing lots of smoke.

I have checked all in settings cli many times its leveled ( but still wants to wander back and left when in stabilise mode.

I have had a 10 day saga of xbee conection problems I have reprogramed many times Jani has reprogramed them , they are ok for about two flights then will not connect.


I am sorry to ask so many questions but it really seems hopless regarding ever being able to do AP with my arducopter.

Can anyone say they would mount a $1000 camera on their arducopter and fly it with confidence?

If so please let me know  and please has anyone got any ideas about any of my many issues?


Thanks for reading this  Nick Wadman  :(








Views: 371

Reply to This

Replies to This Discussion

My Xbee adapters don't have a reset button either, but normally if I plug them in after the Write fails, they automatically trigger a firmware update. You might have to do it a few times to get it to work. I've done this with many Xbees over the years, and never failed to eventually get them working again.

Well I just tried it again with the new update , Alt hold works close to the ground for a few seconds the it climbs out !

Loiter just climbs out!  and does not appear to hold position at all.

I cant unbrick the xbee as it says press the re-stet button that I dont have on the xbee s !


I bought the Arducopter to do AP work as I saw quads and hexacopters on the internet hovering and holding position!

After 10 days straight average 12 hour a day on trying to get this copter to fly and  hold position I am near to accepting the fact it is not going to do what I bought it for.

I am average on computers but not a whizz kid for sure maybe thats the problem! I dont know.

JMD 45, Thanks for your advice , I bought a complete kit with soldered and tested board from J Drones here in Thailand so would expect that the motor/ESC/prop combination wuld be OK ?



Hi Chris,


Thankyou that worked!  But for how long?  Lol I have re-programed 7 times already!

Are you using1016 or 1002 ? I am now on 1016 for the first time .

Where shoud I start looking for a 'loose wire'  ?



But now when I go to terminal it streams random numbers and wont work?  althouh it is working in flight data!



Just make sure your power wires (+ and GND) to the Xbee and the APM pins are really solid. Crimp them if not. If one of those loses connection while data is coming in, it can brick the Xbee as you found.

As for the Alt Hold and Loiter, have faith. Remember you're using Beta software that is being updated every day as we catch bugs etc. This is totally bleeding edge stuff and you are in the first five weeks of its public beta test process. If you're getting frustrated, just take a break for a week or two. By the time you come back, we'll be out of beta and all will be well.

In you'd rather not be a beta tester (and I can understand why you wouldn't) you can always use the ArduPirates Code until we come out of beta. It has been in use since last year and is quite solid and has been used by hundreds of people. Alt Hold and Loiter work well in that, last time I checked. But it's a totally different code base and requires different desktop software, so it will take a little learning

Hi Chris ,


I had no Idea that it was all that new!  I can understand why it has issues , The thing I am a bit angry about is when I travelled to Bangkok to see Jani I told him what I needed to do with the copter ( carry my camera mount that I normally carry on a GSR 260  Gas heli and do AP work using position hold and waypoint navigation)

I think he should have told me that it was not ready at this stage! 

on the website it talks about doing these things but I wish I had known the stage of development as I need to use it now.

I am not really sure where to go from here.

 I dont want to speak out of turn and am sorry to ask the question but will it ever be able to do what the MK mikrocopters can?


I apreciate your help and advice Chris  Best regards Nick

Yes, we are benchmarking against MK. We'll get there soon enough.

I cannot seem to install Ardupirates software to try it .

Is there any way someone could talk me though it ?  on skype maybe?

Hi Chris,

Sorry its me again !  Lol  I spent today trying to install ArduPirates as I am very keen to try it.  But with no luck!

I then contacted my freind in the UK who works with computers in a big way, and useing the program 'team veiwer' he was able to try to install it for me an my computer , But he said this,


First clean up everything (make copies in some other directories if you wish)

  1. copy "libraries" directory from "ardupirates\trunk\ArduPiratesNG" to "arduino" directory
  2. copy libraries directory from "ardupirates\trunk\QUAD\ArduCopter_SuperStable " to arduino directory DO NOT overwrite when asked
  3. create "ArduPiratesNG" directory in the "sketches" diretory
  4. copy the files from "ardupirates\trunk\ArduPiratesNG" (not the libraries dir) to the "ArduPiratesNG" directory in "sketches" diretory
  5. in arduino open sketch "ArduPiratesNG"
  6. compile (should do without errors)
  7. go to http://ardupirates.net/config/ select NG Platform, select your options and generate new config.h
  8. it's quicker if you copy&paste it into the opened config.h
  9. save an recompile

is not enough to work on.  

could you tell us an enplanation of which library? and where is ArduPirates/trunk/arduPiratesNG ?


If there is any chance of some help to get it installed I would be very gratefull.



I have got to the stage of configuration of Ardupirates code in arduino can anyone tell me how to change the values to configure my copter in config h.?



Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service