Hi guys.

I have a problem with my copter in loiter mode. I cant find the sweet spot (throttle input) where the copter hovers at a fix altitude. It tends to go either up or down on its self. I uploaded a video. Could you please give me any sugestions? The RTL function is working with no problems and there the copter can maintain his altitude. Well maybe it is because he is up high in the air ?! 

Views: 3741

Reply to This

Replies to This Discussion

Did you cover the sensor on the apm board with a piece of foam.

Well it came with a foam piece out of stock. I got some new foam today ,will try it out and update this post.

Check your INS_MPU6K_FILTER parameter.

It defaults to 0, but is a setting to 'filter' out vibration from the sensors.

It always defaults to 0, but it drove me nuts figuring why alt holt and loiter were so tempermental.

start with 20 as a setting, mine is currently on 42...

hmmm

I did it to 20 but it wasnt good enough. Then i did it to 98 but the copter turned on his head a few seconds after starting... Im really getting frustrated about APM. I will upload the log and video footage from the "flight". I already had a crash, where the powermodule lost connection to the board due to a wirefailure(?!) which cost me several hundred € to repair the quad. So i soldered the "powerpin" on the board together in order to power it 100% accurate over my ESCs. Only one ESC gives power to the board. So everything should be alright... Well for me I have a suggestion due to the log and videofootage, but will wait with telling it until I get your responses ;). Man this is really starting to frustrate me and im 1 step before getting a DJI flightcontroller xD

Please help me guys!

Attachments:

Yes I got really high quality foam from a store where mattresses are manufactured and put a "huge" bit in the APM. Please read my response to Jason Day, below. There I gave him an update on my copter´s "not flying conditions".

I would not use esc power to run the board. Buy a seperate bec to power it so you get cleaner power. The esc will generate noise on the dc line. Also did you balance your props. What esc are you using and did you program the timings on them or are they simonk esc. Did you run the auto tune on it. If i were you i would clear the eeprom and put in the dephault values and start over. Dont use the wizard. Just go down the list of setups. Also run the compass motor test to check the noise from the motors. Remember take off the prop when setting it up.
Between 10 and 42 would be the number i would aim for. When testing I try to be ready for the crazy moment when it goes wrong. It's not trustworthy..

Are you mounting APM on vibration-damping foam? Altitude hold won't work unless you do that. 

Hi Samuel,

do you have the Tlog from your flight, your rlog doesn´t give too much information, please upload the others.

Ehm what exactly is a Tlog and where do I find it?

What do you mean by "crazy moment" and "it´s not trustworthy"?

Hmm yes I thought about an UBEC as well. I am using Turnigy Plush 30 A ESCs. I didnt run the autotune but I flew one day before and it was soooo smooth in the air and I flew over 20 minutes without having the slightest "uuuuuh... that feels not right". How do I clear the eeprom? What is the compass motor test?

Is there a good and not too pricy UBEC that I can get in Germany(not imported to Germany- everything is imported from China but I mean it is in stock in Germany)

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service