Loiter still not working - trying to get this function to work on APM now since three months and not doing as it should..

Hello Everyone,

i actually continue to have serious issues getting APM to work in e.g. Loiter.

Here, you can see a video with the usual behaviour: http://youtu.be/3HDaQzrht9w

Out of 20 times i tried, loiter worked two times. - In between one time it worked and the next one, i did nothing than to change the battery.

I always waited to have GPS lock, always lifted off in stabilize and then switched over to loiter. Also, i use Auto-Inclination and the latest software as of yesterday.

It's really frustrating to see APM not working as it should - it has cost me by now by far more money and time it would have to buy a WKM with 50 waypoints even.

I have also constructed a special copter due to it crashing so often to use crash bars - see picture below - these are only 1/4 of the aluminum bars which i have destroyed up to now and 1/2 of the props which i have shredded.

Is it really not possible to get this thing flying in loiter ?

If there is somebody here to help with this, i would highly appreciate it.

- If i need to pull logs or settings from the craft, i would be very happy to do so.

Can somebody please help with this one ?

Cheers Florian

Views: 6059

Attachments:

Reply to This

Replies to This Discussion

Curt,

     It sounds very much like a compass issue but it could be the GPS.  It's impossible to say without seeing logs.

     If you're up for looking at your logs I've put together some info on compass interference and right below it on that same page is info on GPS glitches.  It might be good to also look at the COMPASS_ORIENTATION parameter.  It should be set to 0 (if using internal compass) or 8 (if using external compass) on an APM2.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service