So i recently purchased the ublox LEA6 gps from 3DR, I am having a really tough time getting a GPS lock. I have it hooked up to a battery and esc, sitting outside with an unobstructed view of the sky. It's been over an hour and still no lock. I live in IL so coverage shouldn't be a problem. Are there any trouble shooting steps I should/could take?

(full disclosure: I was able to get a lock a couple of times last week, but none this week.)

Views: 4730

Reply to This

Replies to This Discussion

Received my replacement GPS from 3DR today. Haven't tested it yet, but with a cursory inspection I see that the solder joints connecting the ublox chip seem to be of better quality(on my old one, some of them seemed to be missing/incomplete) . I'll check GPS lock tonight and report back...

New GPS works like a charm... good lock in 30 seconds

Same problem. but sometimes it works perfect fixing 7/8 sats in 10 seconds. i think is a soldering problem.

Edit : now i am sure the problem is bad soldering of the ufl cable under the ceramic patch antenna. now i try to resold.

Yes, I returned the GPS to 3DR and the replacement solved the issue

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service