Good evening,

I started a UAV project about a 3 weeks ago after first becoming interested a few months ago. While I have some experience with RTF helicopters and quads, This is my first fixed wing, as well as my first time building/customizing anything or even hearing about flight controllers.

I've spent a loooot of time reading the APM wiki and all the documentation I can find on it. I've fumbled my way through a lot of information I didn't understand initially (including reading every parameter) and have gotten to the point where I can make a guess on how to correct something. I'm mainly looking for general tips and answers on some random questions.

My build-

RMRC Finwing penguin w/ stock 2810 motor & 9" prop

HKpilot32 (I know! I really wanted to get the pixhawk, but my budget really was that tight)

no airspeed sensor

(i think) Neo7 GPS

DX5e w/ spektrum satellite receiver. I also have a turnigy 9x with a 3dr PPM encoder on the way.

Canons100 w/ chdk running kap uas script

hobbyking 3dr clone power module & 915 telemetry

I spent about a day trying to get the HKpilot to work before I wiped everything and installed APM 3.1. I have been pretty damn rough on the airframe with my takeoffs and landings, since I am pretty new to fixed wings.

Random Questions:

1. I have my 60amp ESC/SBEC throttle connection hooked up to my HKpilot output rail, which is where I am getting my servo power at 5.5v. Is this normal/ok?

2. I would like to be able to trigger my s100's kap uav script once airborne with my TX, and turn it back off before landing. Is this possible with a USB->RC output DIY cable? I've seen multiple posts about different cables to make, but I'm not sure which ones offer what options. My girlfriend is going to repossess my balls if I keep buying small items here and there, so I'd like to modify a usb cable if possible.

3. (my main question) Can someone tell me how to set up Flaperons, or at least confirm my guess? I don't care if the autopilot uses them as I'd mainly like to control it myself in manual mode, but it would be a nice bonus. From what I understand, I connect each of the aileron servos into their own RC output (IE RC1 & RC6). Do I change the RC6 channel output to ailerons or flaps? Can I program them to deploy with my trainer switch on the DX5e? Can I also adjust the elevator when deploying flaperons? I've bookmarked a video tutorial on how to do this with the 9x, but I read that I should not use TX mixing.

4. The spektrum satellite range is godawful and is the main reason I'm getting the 9x with a ppm encoder for the 8channel rx. will this setup work better/the same as using the 9x with the orange module & a spektrum rx with the ppm encoder? 

5. What is the cheapest way to improve my range? Is the RFD900 still my best option?

6. I've tested the failsafe about 9 times now by intentionally flying beyond my (very short) range of telem & my TX. The first time, the massive radius of the circle mode scared the hell out of me, but it came home. Every failsafe since then has performed very well (except the battery failsafe). If I change my TX & telem short and long failsafes to continue, will my battery failsafe still return the bird home if it drops too low? I've heard the HKpilot alarm sound on low voltage warning, but never actually trigger a failsafe.

That's about it for random questions. I've been avoiding the forums because there is a wealth of knowledge in the wiki. I think I've taken advantage of it quite a bit, so now I'm just looking for random advice and tips. Feel free to add your 2c, and thank you! 

Views: 182

Reply to This

Replies to This Discussion

One more thing I forgot....

I made the mistake of testing my s100 on the 2nd day of having the penguin and I landed a couple times in a dusty field. The poor retractable lens is now unreliable (because I'm a dopey bastard) and I sometimes get a lens error. I completely dismantled the camera (because i'm a dopey bastard) to see if I could properly clean out the retractable lens. After discovering that I couldn't remove it, I put the camera back together. Now, I have the same problem as before, as well as the very occasional issue of a button being pressed when it shouldn't be. I'm sure I left a screw out somewhere or didn't put something back together 100% where it should be. Is there a very, very thorough guide on how to clean dust out of the lens, or should I just send the camera in to canon? 

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service