Hi How is everyone, nice to be able to meet like minded folk.

Recently I purchased a Jdrone Hexa. Version 2.9.1b, WFT 9 controller, FrSky DFT telemetry, NEO6 GPS.

 I have been losing control of unit. At very close range too. Unit will stop responding until I have hit the air brake(stabilize), shut the air brake off and I have control again.This is very scary as this thing is big enough, fast enough to impale someone and kill!! Especially when I am flying aggressively

 In an open field, the GPS loiter mode, it will start to do a circular motion then unit will take off in some direction(FAST) until I turn it off.

 I have had some crashes previously and had to recalibrate compass, the APM was never damaged or fell out! The Blue LED indicating GPS lock is on, is on when trying loiter mode.

 Also it will lose its altitude after a bit say a 30-60sec with the throttle at %50+ and will not regain the loss. Alt is at 60-80ft when engaged.

Views: 608

Reply to This

Replies to This Discussion

Attach some logs from when you have troubles, then folks can start figuring.

thanks will do

That sounds like magnetic interference. Here's what to do:

1) Mount your APM as high as possible to get away from magnetic interference, and on vibration-isolating foam

2) Upgrade to the latest firmware (3.01), and do the compass and accel calibrations

3) You might want to upgrade to the new GPS that as the compass onboard, which is much easier to mount far from sources of interference. It's easy to modify your APM to use the external mag. 

Thanks Chris

I did the upgrade and it made no difference in loiter mode. Perhaps the GPS module did get damaged, I"ll figure out how to get a log posted and go from there. The mod for the 3DR looks easy enough. 

Thanks I appreciate your help

 Completely lost control. My apm will not arm, I can see the values change on the controller calibration screen on MP but apm will not arm. Using 3.01. Got a flashing A red led, steady red ACTIVE led and the TX fast flash RX steady flash

BALLS I got a shoot this weekend! and no bird

I lost control on my hexacopter yesterday (  Sep /2 /2013 )  I had very similar situation to yours:

EQUIPMENT:  APM 2.5 + 3DR GPS  + 3DR power module

FRAME DJI 550 , charged LIPO battery 4000mah 4s.

I had 7 flights yesterday with Firmware 3.01 7th was not so lucky.

I always wait few minutes after changing battery for system to stabilize and pressure sensor to get stable.

I tried modes : STABLIZE , ALT HOLD, RTL, LAND,  AUTO with 4 waypoints, LOITER. I also tried FENCE option with ALTITUDE and CIRCLE.  Everything worked BUT  on 4th flight when I switched from STABILIZE to RTL  ( my copter was very close to lunch maybe 3 - 5 meters ) it started a wide circle and flew away with no control. I suddenly switched to STABILIZE and it stopped. I could take over.

On 7th flight, I started with STABILIZE and I increased altitude to MAX ( I was trying to see how FENCE will work. )

I increased altitude just above HOME position then when it hit the MAX ALTITUDE it should RLT and LAND  but again it went with wide circle and flew away. This time with great speed and far. I switched modes between STABILIZE - ATL HOLD - LAN to gain the control but it was far  about 100 meters out and 40 meters high. I am attaching my logs here .

as far as I can see : GPS reception was OK, battery voltage OK.

 

I have my APM in box located BETWEEN upper and lower plates of the frame which means that it might me susceptible to a lot of electromagnetic field, magnetometer was calibrated and hexacopter was flying fine.

 

Attachments:

This is my CIRCULAR fly away : please see how often I switched Return To Launch. GPS as you can see was very accurate and shows exactly what happend. Via software HOME is where red arrow points. So what HAPPEND?

 

HI Jacek

I haven't heard from anyone else on this issue. We have different gear and same problem! I am a newbie and won't be much help I am afraid. How did u get this flight layout? I wish someone would look at my data and give me some insight. Just might bite the bullet and get the new 2.6APM with the 3DR. $200 will fix the issue sadly.

Todd

Todd the problem is that build-in compass on my APM 2.5 which is too close to power distribution board. That is why new 3dr GPS WITH COMPASS on a post fixes the problem.

It is called toilet bowl effect. Known before but now when compass is used a lot in firmware 3.01 it is very important to isolate compass from EMF sources.

Mine had also done the same thing with the "toilet bowl effect" 

i am in the process of fixing up my quad after an extremely bad crash and will use the external compass instead of the compass in the APM, 

hopefully this will fix the issue!

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service