I'm still having the same problem in Mission Planner when I enter the Magnetic Declination in the Planner, if I enter a value "-3.6", "-3,6", etc, the value it assumes will be "-36", so it's not reading the decimal separator. I'm having this problem in all revisions from this version (my keyboard is in portuguese, decimal separator is defined as ", (comma)"). I always go to the CLI and set it up there, since in CLI works well (setup -> declination -3.6). As this is not a big deal, I haven't mentioned earlier, however, lot's of folks could be complaining about compass not working well or not showing heading correctlly, and it could be as simple as this.

They might be entering a decimal value for instance 2.2, and the declination would be set to 22. I recomend everyone checks after setting it.

I changed the decimal separator to ". (dot)" and now it works fine. So if your decimal separator in windows does not match the Mission Planner, it will not assume it. Go to regional settings and use the dot for decimal separation and comma for grouping.

Views: 601

Reply to This

Replies to This Discussion

Thanks for that. I've passed it on the Michael, but in the future please post these issues in the Issue Tracker. The developers won't see them otherwise.

Ok, sorry, I didn't knew. Thank you.

Hi

I have problem to enter the Degrees in apm planner it change the numbers back to 0 ?

if I print 4.25 it change the self- back to 0 again ? what am I doing wrong I am in "setup" hardware and compass.


Timo

Sweden

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service