Hi there,

I can’t get the APM Planner 1.0.55 to connect via the MAVLink all weekend. I’m running APM V2.22 firmware. Running Windows 7 64 bit.

What I’ve done so far to try and troubleshoot this issue:

 

1.)    With IMU switch in position 0 (toward the servo pins) I’ve ran the GPS test using the CLI. I have GPS lock (running MediaTek 1.6 GPS) and checked the coordinates. The coordinates are accurate (my house).

2.)    I moved the switch back to position 1 toward the GPS port and made sure the baud rate is 115200. Unplugged USB cable and plugged it back in and tried to connect via MAV Link. 30 seconds pass and I get the time out message.  (My first test demonstrates I have the GPS plugged into the right port and have an accurate GPS lock.)

3.)    I’ve reinstalled the com port, reloaded the firmware, and updated my planner.

4.)    Made sure “Set RTS on Close” is checked under the com port properties.

5.)    Downloaded FTDI Drivers and attempted to update drivers but my Windows 7 says the best driver is already installed.

6.)    I’ve tried plugging in my LiPo battery first, waiting for GPS lock and then connecting.

7.)    I’ve download the Happy Kilmore GCS and tried to connect. The status read “Connected on COM4 at 115200 but the GPS Type reads “0.00%”. It never moves past this point.

8.)    I’ve read other posts on this forum to see what other people did in the past and I’ve spent many hours trying to get this working and I just can’t get it to work.

 

What is working at this point?

1.)    CLI connection in switch position 0 works every time.

2.)    Radio communication works

3.)    IMU sensors are working (gyros, pressure, accelerometers, gps).

4.)    Modes work. Running on battery power alone I can switch to different modes and see APM take over and move the servos, engine, ect.

 

Any ideas on how to get APM Planner to connect via MAVLink at this point are more than welcome.

 

Thank You,

 

Jeff Johnson

Views: 10487

Reply to This

Replies to This Discussion

Omar,

 

Did you try these steps? Keep your battery out of it for now. Just try to power the board with USB. That means no radio or servos will be involved yet either.

 

For me the answer turned out to be the sequence and timing in which I was trying to connect. Here is what I would recommend:

 

1.) Update to the latest version of the APM Planner

2.) Update your Ardupilot Firmware to the latest version

3.) Move your switch so that it is away from the pin headers (towards your GPS connector).

4.) Push the reset button on your IMU board.

5.) Watch for the A and B lights to start blinking and at this moment click connect on your APM Planner software.

6.) If it doesn’t connect after a few seconds, cancel the connection attempt and try again. Just hit the reset button (don’t just unplug the USB cable, push the reset button) and wait for the A and B lights to start flashing and click “connect”.

 

This specific timing seems to only be required on my laptop but it works. My desktop is much less temperamental so it makes me think it’s a USB related issue on my laptop. It was also suggested to me to just uninstall not only the FTDI drivers but all of my USB devices in the devices manager as well. After a reboot the Windows should reinstall all of the drivers which may help.

 

I know there is a message that says it may be waiting for GPS lock but that probably not the case since you can connect via MAVLink without a GPS lock. I do this all the time since I can’t get a lock in my basement.

Hello Jeff,

 

Yes, I followed these instructions, I used the newest mission planner and updated to the latest firmware, but the A and B lights are not blinking, I've waited several minutes.

I seems the gyro won't initialize in the newest firmware.

 

I tried the older firmware 2.0.23 the gyro did initialize, did setup and all in CLI but when I plugged the flight battery, the green light stays solid and not blinking and I wasn't able arm/disarm the quad.

 

Any ideas?

I'm sorry the only thing I can think of is it may be similar to an issue I had with a previous board. See this thread:

http://diydrones.com/forum/topics/apm-mega-gyro-calibration?comment...

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service