Hi there,

I can’t get the APM Planner 1.0.55 to connect via the MAVLink all weekend. I’m running APM V2.22 firmware. Running Windows 7 64 bit.

What I’ve done so far to try and troubleshoot this issue:

 

1.)    With IMU switch in position 0 (toward the servo pins) I’ve ran the GPS test using the CLI. I have GPS lock (running MediaTek 1.6 GPS) and checked the coordinates. The coordinates are accurate (my house).

2.)    I moved the switch back to position 1 toward the GPS port and made sure the baud rate is 115200. Unplugged USB cable and plugged it back in and tried to connect via MAV Link. 30 seconds pass and I get the time out message.  (My first test demonstrates I have the GPS plugged into the right port and have an accurate GPS lock.)

3.)    I’ve reinstalled the com port, reloaded the firmware, and updated my planner.

4.)    Made sure “Set RTS on Close” is checked under the com port properties.

5.)    Downloaded FTDI Drivers and attempted to update drivers but my Windows 7 says the best driver is already installed.

6.)    I’ve tried plugging in my LiPo battery first, waiting for GPS lock and then connecting.

7.)    I’ve download the Happy Kilmore GCS and tried to connect. The status read “Connected on COM4 at 115200 but the GPS Type reads “0.00%”. It never moves past this point.

8.)    I’ve read other posts on this forum to see what other people did in the past and I’ve spent many hours trying to get this working and I just can’t get it to work.

 

What is working at this point?

1.)    CLI connection in switch position 0 works every time.

2.)    Radio communication works

3.)    IMU sensors are working (gyros, pressure, accelerometers, gps).

4.)    Modes work. Running on battery power alone I can switch to different modes and see APM take over and move the servos, engine, ect.

 

Any ideas on how to get APM Planner to connect via MAVLink at this point are more than welcome.

 

Thank You,

 

Jeff Johnson

Views: 10425

Reply to This

Replies to This Discussion

can you guys test the pressure sensor from the cli.

I've tried 4 machines already, but no luck.

 

I can type in anything into the terminal and it won't do anything but go to the next line after I hit enter.

Hi Michael,

Ive loaded the APM2.23. Here is the cli airpressure test

Attachments:

Shamir,

Well, I seem to remember this happening to me as well. I’m still a novice at this too so all I can do is share with you what I did to get my board up and running.

 I remember one day I couldn’t get my board to complete the initialization either. It was very similar to what you are experiencing. I tried to reload the firmware through the APM planner several times but it didn’t seem to work. I thought maybe if I tried to load my firmware using the Arduino software instead of the APM Planner I would get a different result. You can also get a command line interface using the Arduino software to run your CLI tests.

I decided to upload an older version of the APM firmware using Arduino. It worked and I was able to run some of the tests from the Arduino CLI. I then closed Arduino and went back to the APM Planner and used the Update Firmware utility and that worked too. After that I was able to connect using the APM Planner Terminal and my problem was solved.

Basically what I’m suggesting is an alternative method for re-loading your firmware. Have you ever messed around with Arduino?

If not read these links for more information:

Arduino Software:

http://arduino.cc/en/Guide/HomePage

APM instructions on using Arduino to load your firmware:

http://code.google.com/p/ardupilot-mega/wiki/Code

ArduCopter / Arduino Source Files:

http://code.google.com/p/arducopter/downloads/list

Warren,

So just to be clear, in your screenshot your running APM 2.23 under the terminal window while in flight mode (switch mode 1).

 

If you move your switch back to mode 0 and run the “imu” test does your board complete the gyro calibration and start giving you output values as you move your board on each axis?

 

The values should change as you tilt it and turn it on each axis and then return to 0 if you hold it still.

The reason I’m asking is because my first APM board had a bad gyro and the newer firmware versions wouldn’t finish the gyro calibration because of this. Basically the A and B lights would just blink endlessly until I unplugged the board. I don’t recall if this kept me from connecting via MAVlink on that board but it’s just a thought…

Jeff

Hi Jeff,

Yes, I was in flight mode (switch mode 1) during those screenshots. From the screenshot file name you can tell which firmware was loaded at the time. APM2.23 or APM2.23SIM

This screenshot is in CLI switch mode 0.

Test "imu" completes, all 0s, all output values while being tilted, all return to 0 when still.

I can only connect via MAVlink Flight mode (switch mode 1) with "APM2.23 Sim" firmware loaded, not with "APM2.23"

Waz

Attachments:

Not sure if this is the correct forum but - ever since I updated APM Planner to 1.0.67 my XBEE ground station module causes the mouse to loose control.  This has occured on both my 2 laptops and my desktop.  I am running XP Pro on one laptop and Windows 7 Professional on the desktop and Windows 7 Starter on the other laptop.

 

Any ideas?

 

Allen

Allen, can you explain a bit more? What's an "XBEE ground station module"? I'm not seeing any problems on my machines. 

Chris:

 

I figured it all out.  The main problem was the drivers for the USB/Serial converters that connect the XBee modules to the PC (my ground station).  I don't know how or why but they became inoperative and caused the mouse to loose control.  I went into Control Panel then to Device Manager and deleated the usb and comm port for the XBee interface.  I re-installed the XBee and it works fine  now.

 

Just one of those days.  I updated APM Planner to 1.0.67 and uploaded the new .42 Beta Firmware and maybe I screwed something up along the way.

 

I test the Quad and Hexa tomorrow.  I don't think I have ever posted pictures so here are my two birds.  The dome on the Quadra is from a $25 plastic lamp post ball that I cut down to 4.5" in height.  Added four clips on the arms and routered four slots on the plastic ball and the rest is what you see.

 

Thank you again for all your help and to the great developers who have done a remarkable job.

 

Allen

I've had my mouse go wacky too and I can reproduce it. I can also guarantee that it will not happen (in my case  ;)   ). The issue comes into play when the copter is powered up before the PC-side modem. What happens is Winblows thinks that there is a mouse attached to the USB Serial Port due to the presense of data coming over the port when it is powered up. If you always power up the PC and PC-side modem/xbee before the arducopter, you shouldn't see this problem... at least that's what I've found...

John:

 

That makes complete sense.  I was wondering if thre was a possibility that the PC would sense something other that a modem.  I will try it out tomorrow.

 

Thanks

 

Allen

Hello,

 

My problem is the same as Jeff and Shamir, in the terminal interface on fly mode when I type "load_all" and hit enter nothing happened,  it just disappears.

I also can't connect via mavlink. 

Setup in CLI mode is working fine.

But when I plugged the flight battery in flight mode, the red and green LEDs didn't blink, so I couldn't start the quad.

IMU and air pressure in CLI is also working fine.  It's just mavlink that's causing problem.

 

I am using win xp, tried another laptop with windows 7 and it still won't connect.  I also already disabled firewall.

 

What went wrong? I tried older versions and it didn't work.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service