Mavlink not connecting, "No Heartbeat Packet Received" error.

I successfully installed the firmware onto Pixhawk with APM2.

But the wizard menu did not show to allow me to do the wizards to set up the Pixhawk.

I downloaded and installed Mission Planner and I was able to confirm the firmware was installed and was able to select the setup wizard.

However, it fails while trying to connect with Mavlink with timeout and "No Heartbeat Packet Received" error.

I have 3 USB ports on my ASUS X53E laptop and tried all of them with the same results. Running Windows 7 Home Premium Service Pack 1.

The Pixhawk shows normal led indication, the GPS also show normal led indications, the RX (R7008SB) is showing power with red LED and the safety switch is flashing quickly.

On power up with usb connection the Pixhawk does the correct tune followed by two beeps to indicate ready and running...

SO what now I am stuck?  Please help.

Views: 13864

Reply to This

Replies to This Discussion

After reading this Thread: http://diydrones.com/forum/topics/no-heatbeats-from-mavlink-the-sag...

I disconnected my GPS and all is well.

Problem Solved... on to the next hick-up...

Bringing up an old thread. 

I am having a similar issue and I was wondering what you did for GPS since you said disconnecting it was the solution?

Do you not need GPS?

My project isnt exactly the same but for my airplane I wish to have it follow waypoints via GPS. 

Thanks in advance.

Hi,

I have the exact same problem and I check the link I found in this thread and I tried connecting without peripherals (external gps) and I still have the same problem. Please help.

guys i have the same issue i am using apm 2.5 and i have 2 board with the same issue there is nothing connected to them at all andit keeps trying to connect till it displays the message "no heartbeat packets received " what am i supposed to do ?

I have solved my issue finally ! I connected the apm board using USB cable then before pressing the connect button on the mission planner I installed the new firmware (in my case the latest quad x firmware for apm2.5) then after that it worked well and connected to the mission planner naturally. I also didn't have the cyclic leds (red blue yellow) only the green light was working but its fixed now and everything works fine .
I will try your soulutiin with another board that didn't respond to my way @iSkyMaster

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service