Replies

  • Hi. In an attempt to simultaneously send the data from the telemetry port of APM 2.5, both to the 3DR radio and the Minimosd, I bought a "Y" type cable, similar to that seen in the photo.


    In summary, the results obtained were a good radio remote reception, but on the OSD screen only zeros were observed.
    In order to solve the problem, at first, following some hints found on the internet, I updated both the MinimOSD and APM2.5 firmware. The result was always the same while the problem was not solved at all.


    After got stuck and wasting many hours (actually months) , I finally found a permanent solution.


    As a last resort, before throwing away the OSD, I checked the wiring routes and discovered that it was wrong.
    I could never have imagined that it could have been a defect in the manufacture of the goods.


    The thing to check is that the cable coming out of the APM pin TX reaches both the OSD RX and the RX of 3DR radio.
    In my case I had to cut and splice a couple of cables.


    I suspect that I am not the only person who has had this problem.

    Good luck!
    Juan Manuel de Santiago

    3702340515?profile=original

    3702340281?profile=original

  • Big thanks to YOU! After many days, after reading your post I finally fixed minimosd updating problem. What I done - Upgraded minimosd to Arducam 2.0  Firmware using 1.9 charset. What it do is on boot up requesting data from APM, so TX wire should be connected too, without TX wire it didn't worked! I have HKPilot Mini Apm with 3.1.5 firmware with HKPilot minimosd.

    Eric B. said:

    Hello, I was having similar problems with data like battery voltage not updating on minimosd.  It seems like lots of people are having issues of this type and usually the problems are unresolved, so I thought I would try to put my solution out there in case it helps people.

    I have the mini APM and micro minimosd with KV team mod from readytoflyquads.  I'm running AC3.2.1.  Originally I put minimosd extra 2.2 FW on and the battery voltage would show up as zero.  If I armed the quadcopter the voltage would update once, then keep that one value and not update anymore.  Throttle percentage and pitch angle/artificial horizon would update fine.  Here's a list of things I read people had tried and worked for them, but didn't work for me:

    -update to minimosd extra 2.4 r800 FW

    -power minimosd from separate 5V source

    -change SR0 parameters in mission planner to various values. Mission planner still changes these back to whatever values it wants, but it doesn't seem like these values are critical

    -add telemetry delay of 10 seconds in mission planner.  Someone recently said this worked for them.

    -remove minimosd Tx plug so it just receives.  Apparently this had worked for someone.

    Then I tried a second micro minimosd that I bought that had Arducam 2 FW preinstalled and it worked; voltage updated at all times, like it should.  I downgraded the first micro minimosd to Arducam 2.0 FW.  I also uploaded the character set from the config tool package in the link below.

    Here are the links where I got the FW stuff:

    https://code.google.com/p/arducam-osd/downloads/list

    https://code.google.com/p/arducam-osd/downloads/detail?name=MinimOS...

    I hope this helps anyone that is still stuck with the problem I had.

  • Hello, I was having similar problems with data like battery voltage not updating on minimosd.  It seems like lots of people are having issues of this type and usually the problems are unresolved, so I thought I would try to put my solution out there in case it helps people.

    I have the mini APM and micro minimosd with KV team mod from readytoflyquads.  I'm running AC3.2.1.  Originally I put minimosd extra 2.2 FW on and the battery voltage would show up as zero.  If I armed the quadcopter the voltage would update once, then keep that one value and not update anymore.  Throttle percentage and pitch angle/artificial horizon would update fine.  Here's a list of things I read people had tried and worked for them, but didn't work for me:

    -update to minimosd extra 2.4 r800 FW

    -power minimosd from separate 5V source

    -change SR0 parameters in mission planner to various values. Mission planner still changes these back to whatever values it wants, but it doesn't seem like these values are critical

    -add telemetry delay of 10 seconds in mission planner.  Someone recently said this worked for them.

    -remove minimosd Tx plug so it just receives.  Apparently this had worked for someone.

    Then I tried a second micro minimosd that I bought that had Arducam 2 FW preinstalled and it worked; voltage updated at all times, like it should.  I downgraded the first micro minimosd to Arducam 2.0 FW.  I also uploaded the character set from the config tool package in the link below.

    Here are the links where I got the FW stuff:

    https://code.google.com/p/arducam-osd/downloads/list

    https://code.google.com/p/arducam-osd/downloads/detail?name=MinimOS...

    I hope this helps anyone that is still stuck with the problem I had.

    • I had the same issue. No voltage and GPS updates. Updates only once on arming. I have the Arducam 2.0 preinstalled on OSD, Apm mini 3.1 board which has only SR0 and SR1, AC 3.2.1. Tried dozens of SR parameters. Nothing helped. This OSD worked fine (after ENABLE TELEMETRY button) in my old Crius AIOP v2, AC 3.1.5 with only the controllers TX wire to OSD RX. I tried to connect the another wire (TX from OSD to RX of APM and it worked like a charm.

      So, my conclusion is: IT WILL NOT WORK with one wire if there is nothing another on that port, that will request data (radio telemetry, for example). I think in my CRIUS AIOP, OSD port was the same with the main port for USB connection (it uses USB-serial (FTDI) chip). And APM mini has separate port, whis is not forced for updates from the APM firmware (at least, not all the parameters). Or, maybe, 3.1.5 firmware had all the parameters forced, which 3.2.1 doesn`t.

      Cheers!

    • Had this problem and after a lot of retries I figure out that we can't use telemetry to setup or force the OSD on MP. To force it to work it's necessary to plug USB cable and do it. After reboot the quad and voltage should start updating...

  • Hi Santosh. I had the same issue; values reset on Arm and it stopped updating. That was with v2.2 with v2.2 charset. I was also having issues getting the 3pos toggle to work. Both problems solved by updating to..

    Firmware: https://code.google.com/p/minimosd-extra/downloads/detail?name=Mini...

    Charset: https://code.google.com/p/minimosd-extra/downloads/detail?name=Mini...

    Software: https://code.google.com/p/minimosd-extra/downloads/detail?name=CT%2...

    Hope that helps :)

    Paul

    • thanks but on my PC I am trying to connect minimosd using ftdi tool but it is not showing any port in device manager i think windows 8 is unable to install correct drivers 

      • 3702677236?profile=original

        After updating firmware and charset and connecting telemetery transmitter I am viewing this. How I can see real values like GPS coordinates and battry voltage 

        • Are you sure it's connected correctly?

          Both the telemetry TX and MinimOSD should be connected to the APM telemetry port using the 'Y' lead. Video out from the cam goes to the MinimOSD then out to the video TX.

          Always power up the camera first, give it a few seconds, then power up the APM.

          • Yes I am using Y cable for connecting OSD and Telemetery 

            can i see gps/battery voltage and other paramaters without arming APM board or it need to be armed 

This reply was deleted.

Activity

DIY Drones via Twitter
RT @chr1sa: My talk on PX4 and FAA certification is coming up at 1:45 PST today on the PX4 Dev Summit livestream. Includes some cool new st…
Tuesday
DIY Drones via Twitter
RT @seesharp: I'm tuned into the PX4 / Dronecode free live conference. Great stuff. Microsoft AirSim talk in 10 minutes. https://t.co/0zbZ2…
Monday
DIY Robocars via Twitter
RT @masato_ka: 距離センサを3つとESP32を付けたラジコンカーをDonkeyCarライクにNNで自動走行。3層FC極小モデルをTensorFlow Lite for microcontrollerで動かしてる。機体は借り物でRumiCarって言います。Tenso…
Monday
DIY Robocars via Twitter
RT @SmallpixelCar: My car was able to go all the way autonomously until the crosswalk. It was only 100 yards from the target. What should b…
Saturday
Liam left a comment on Agricultural UAVs
"Hi
I'm Liam from T-MOTOR. I would like to reach out to see if there is any possibility for us to work together.
We are a propulsion system manufacturer who offers motors, propellers and ESCs for all kinds of drone applications which vary from secur…"
Jun 30
DIY Robocars via Twitter
RT @SmallpixelCar: Smart move. The car used the shadow to guide it through the bridge. This was never in the training samples. But it learn…
Jun 30
DIY Robocars via Twitter
RT @SmallpixelCar: Getting closer to the target. Single camera. Untrained road. https://t.co/Wsr7RwDamj
Jun 29
Richard Cox left a comment on Australia
"Anyone in the DIYDRONES Australian subgroup based in Alice Springs, NT?
I am experimenting with Ardupilot (standard Arduplane), Pixhawk 4 FC in a 4-ch
RC "AXN Floater Jet" foamy plane..."
Jun 29
Omar Sykes left a comment on Australia
"Hi everyone, I am looking for someone who is good at drone building, repair and software in Adelaide. Please give me a call on 0477 319 219."
Jun 29
DIY Robocars via Twitter
RT @RoboticMasters: #donkeycar https://t.co/czuLoVRcA4
Jun 29
DIY Robocars via Twitter
https://t.co/DKQbNTbz0g
Jun 29
DIY Robocars via Twitter
RT @RoboticMasters: Donkey car, car car car car car car; Donkey car, car car car car car car; Donkey Car. Anyone like our tiny tiny donkey…
Jun 29
DIY Robocars via Twitter
RT @SmallpixelCar: After improving DBSCAN speed, I can get 11 frame per second on @NVIDIAEmbedded Jerson Xavier MAXN mode and the autonomou…
Jun 26
DIY Robocars via Twitter
RT @Heavy02011: Join us at next Virtual Race League: ⁦@diyrobocars⁩ Race #4 - Parking Lot Nerds, August 1st https://t.co/5KUpu7VGaH
Jun 25
DIY Robocars via Twitter
RT @SmallpixelCar: #CUDA implementation should be easy, because most of the time is on distance calculations berween two points and if the…
Jun 25
DIY Robocars via Twitter
RT @SmallpixelCar: This is the view from the car. Even my lanenet inference is fast on @NVIDIAEmbedded Jerson Xavier, DBSCAN clustering tak…
Jun 25
More…