Replies

  • Hi. In an attempt to simultaneously send the data from the telemetry port of APM 2.5, both to the 3DR radio and the Minimosd, I bought a "Y" type cable, similar to that seen in the photo.


    In summary, the results obtained were a good radio remote reception, but on the OSD screen only zeros were observed.
    In order to solve the problem, at first, following some hints found on the internet, I updated both the MinimOSD and APM2.5 firmware. The result was always the same while the problem was not solved at all.


    After got stuck and wasting many hours (actually months) , I finally found a permanent solution.


    As a last resort, before throwing away the OSD, I checked the wiring routes and discovered that it was wrong.
    I could never have imagined that it could have been a defect in the manufacture of the goods.


    The thing to check is that the cable coming out of the APM pin TX reaches both the OSD RX and the RX of 3DR radio.
    In my case I had to cut and splice a couple of cables.


    I suspect that I am not the only person who has had this problem.

    Good luck!
    Juan Manuel de Santiago

    3702340515?profile=original

    3702340281?profile=original

  • Big thanks to YOU! After many days, after reading your post I finally fixed minimosd updating problem. What I done - Upgraded minimosd to Arducam 2.0  Firmware using 1.9 charset. What it do is on boot up requesting data from APM, so TX wire should be connected too, without TX wire it didn't worked! I have HKPilot Mini Apm with 3.1.5 firmware with HKPilot minimosd.

    Eric B. said:

    Hello, I was having similar problems with data like battery voltage not updating on minimosd.  It seems like lots of people are having issues of this type and usually the problems are unresolved, so I thought I would try to put my solution out there in case it helps people.

    I have the mini APM and micro minimosd with KV team mod from readytoflyquads.  I'm running AC3.2.1.  Originally I put minimosd extra 2.2 FW on and the battery voltage would show up as zero.  If I armed the quadcopter the voltage would update once, then keep that one value and not update anymore.  Throttle percentage and pitch angle/artificial horizon would update fine.  Here's a list of things I read people had tried and worked for them, but didn't work for me:

    -update to minimosd extra 2.4 r800 FW

    -power minimosd from separate 5V source

    -change SR0 parameters in mission planner to various values. Mission planner still changes these back to whatever values it wants, but it doesn't seem like these values are critical

    -add telemetry delay of 10 seconds in mission planner.  Someone recently said this worked for them.

    -remove minimosd Tx plug so it just receives.  Apparently this had worked for someone.

    Then I tried a second micro minimosd that I bought that had Arducam 2 FW preinstalled and it worked; voltage updated at all times, like it should.  I downgraded the first micro minimosd to Arducam 2.0 FW.  I also uploaded the character set from the config tool package in the link below.

    Here are the links where I got the FW stuff:

    https://code.google.com/p/arducam-osd/downloads/list

    https://code.google.com/p/arducam-osd/downloads/detail?name=MinimOS...

    I hope this helps anyone that is still stuck with the problem I had.

  • Hello, I was having similar problems with data like battery voltage not updating on minimosd.  It seems like lots of people are having issues of this type and usually the problems are unresolved, so I thought I would try to put my solution out there in case it helps people.

    I have the mini APM and micro minimosd with KV team mod from readytoflyquads.  I'm running AC3.2.1.  Originally I put minimosd extra 2.2 FW on and the battery voltage would show up as zero.  If I armed the quadcopter the voltage would update once, then keep that one value and not update anymore.  Throttle percentage and pitch angle/artificial horizon would update fine.  Here's a list of things I read people had tried and worked for them, but didn't work for me:

    -update to minimosd extra 2.4 r800 FW

    -power minimosd from separate 5V source

    -change SR0 parameters in mission planner to various values. Mission planner still changes these back to whatever values it wants, but it doesn't seem like these values are critical

    -add telemetry delay of 10 seconds in mission planner.  Someone recently said this worked for them.

    -remove minimosd Tx plug so it just receives.  Apparently this had worked for someone.

    Then I tried a second micro minimosd that I bought that had Arducam 2 FW preinstalled and it worked; voltage updated at all times, like it should.  I downgraded the first micro minimosd to Arducam 2.0 FW.  I also uploaded the character set from the config tool package in the link below.

    Here are the links where I got the FW stuff:

    https://code.google.com/p/arducam-osd/downloads/list

    https://code.google.com/p/arducam-osd/downloads/detail?name=MinimOS...

    I hope this helps anyone that is still stuck with the problem I had.

    • I had the same issue. No voltage and GPS updates. Updates only once on arming. I have the Arducam 2.0 preinstalled on OSD, Apm mini 3.1 board which has only SR0 and SR1, AC 3.2.1. Tried dozens of SR parameters. Nothing helped. This OSD worked fine (after ENABLE TELEMETRY button) in my old Crius AIOP v2, AC 3.1.5 with only the controllers TX wire to OSD RX. I tried to connect the another wire (TX from OSD to RX of APM and it worked like a charm.

      So, my conclusion is: IT WILL NOT WORK with one wire if there is nothing another on that port, that will request data (radio telemetry, for example). I think in my CRIUS AIOP, OSD port was the same with the main port for USB connection (it uses USB-serial (FTDI) chip). And APM mini has separate port, whis is not forced for updates from the APM firmware (at least, not all the parameters). Or, maybe, 3.1.5 firmware had all the parameters forced, which 3.2.1 doesn`t.

      Cheers!

    • Had this problem and after a lot of retries I figure out that we can't use telemetry to setup or force the OSD on MP. To force it to work it's necessary to plug USB cable and do it. After reboot the quad and voltage should start updating...

  • Hi Santosh. I had the same issue; values reset on Arm and it stopped updating. That was with v2.2 with v2.2 charset. I was also having issues getting the 3pos toggle to work. Both problems solved by updating to..

    Firmware: https://code.google.com/p/minimosd-extra/downloads/detail?name=Mini...

    Charset: https://code.google.com/p/minimosd-extra/downloads/detail?name=Mini...

    Software: https://code.google.com/p/minimosd-extra/downloads/detail?name=CT%2...

    Hope that helps :)

    Paul

    • thanks but on my PC I am trying to connect minimosd using ftdi tool but it is not showing any port in device manager i think windows 8 is unable to install correct drivers 

      • 3702677236?profile=original

        After updating firmware and charset and connecting telemetery transmitter I am viewing this. How I can see real values like GPS coordinates and battry voltage 

        • Are you sure it's connected correctly?

          Both the telemetry TX and MinimOSD should be connected to the APM telemetry port using the 'Y' lead. Video out from the cam goes to the MinimOSD then out to the video TX.

          Always power up the camera first, give it a few seconds, then power up the APM.

          • Yes I am using Y cable for connecting OSD and Telemetery 

            can i see gps/battery voltage and other paramaters without arming APM board or it need to be armed 

This reply was deleted.

Activity

DIY Drones via Twitter
Welcome to the new DIY Drones design!. You may have noticed that DIY Drones looks a little different today. That's… https://t.co/cg2EmeDGMQ
12 hours ago
DIY Drones via Twitter
New! Online Training on Drones for Disaster Response https://t.co/brqRuujjY2
yesterday
DIY Robocars via Twitter
https://t.co/8EMCvYW6oz
Tuesday
DIY Robocars via Twitter
RT @OttawaAVGroup: We are going to try something new this week. We will be having a drop-in style meeting Wednesday @ 7-9pm EST. Pop in and…
Monday
DIY Robocars via Twitter
RT @tawnkramer: Thanks Everyone for another fun virtual race! Amazing Ai racers competing head-to-head, Virtual Makers Fair event. Catch us…
Sunday
DIY Robocars via Twitter
RT @make: Find out the latest from @diyrobocars at 10am PT from @chr1sa of @3DRobotics on Virtually Make Faire! #makerfaire #maketogether #…
Saturday
DIY Robocars via Twitter
RT @Heavy02011: Join us Saturday online: Virtual Race League: @DIYRobocars Race #2 - Parking Lot Nerds https://t.co/aJUu4sdutx #Meetup via…
Saturday
DIY Robocars via Twitter
RT @donkey_car: Yay, we are part of the virtual @makerfaire with @diyrobocars. Come see our race or better yet train a model and race with…
May 21
DIY Robocars via Twitter
RT @chr1sa: The @DIYRobocars Virtual AI Race is going to be part of the virtual @makerfaire on Sat! https://t.co/wnMDAboLID
May 20
DIY Robocars via Twitter
RT @tawnkramer: Please join us next week for our second DIYRobocars online race. We will be using a new Mountain Track course! https://t.co…
May 19
DIY Robocars via Twitter
RT @SmallpixelCar: I realized that the size of the cones in @diyrobocars is known. If we can detect the bounding box, which can be done wit…
May 19
DIY Drones via Twitter
RT @chr1sa: Our next @DIYRobocars autonomous car virtual race is this Saturday. Sign up here to compete or just spectate on @Twitch https:/…
May 19
DIY Drones via Twitter
Definitive Guide to Setup Drone Delivery System https://t.co/7ibwcgF24h
May 19
DIY Robocars via Twitter
RT @DAVGtech: The next @diyrobocars virtual robocar race is this Saturday. One of many interesting issues we are taking a stab at is "how c…
May 18
DIY Robocars via Twitter
RT @chr1sa: cc @DIYRobocars @donkey_car https://t.co/ewbyqZ3xC0
May 18
DIY Robocars via Twitter
RT @chr1sa: This is the technique that many of the @DIYRobocars racers use to estimate their localization position on the track https://t.c…
May 18
More…