I have just bought a Minim OSD and got it all soldered up. I am running it on the ground rather than in the plane as I want to be able to see the OSD even if the video glitches when I am at long range.


I have encountered a strange problem that I am hoping I can get some help with. When I plug the OSD into my goggles or computer without an input video stream into the OSD, I can see the OSD perfectly with a black background. All of the information coming from the plane is there and it responds. Once I plug in the video feed from my video Rx, the OSD information just dissapears, all I can see is the video feed. It's clear, but there is no OSD information any more. As soon as I unplug the video input into the OSD, the OSD information reappears on my screen, with a black background.


I did some playing around, and it appears that the PAL signal being put out by the OSD is a PAL M type. Which is 60Hz and 15.750kHZ horizontal freq. I checked the specs of my PAL camera on the plane, and it is 50Hz with a 15.625kHz horizontal freq, also known as PAL N.


Could this difference by the cause of my problem? Is the minimOSD having problems syncing the camera feed to the OSD layer? Is there any way to fix this in the firmware?




Views: 10766

Reply to This

Replies to This Discussion

Hello ,

I had also issues with flickering, using a Sony NEX camera, thus going through an AV converter hdmi->analog video.

I first used a compact HDMI to AV converter board, specifically made for the Sony NEX. This never worked : always got flickering.

I also thought it was a problem with minimOSD and tried various things without success. I then told myself that the cause was maybe elsewhere in the video chain. So I changed the HDMI-to-AV by another one and success! I do not know why this particular converter caused mimimOSD to flicker.

Im using a regular ebay board fpv camera, sony 700tvl. Any suggestions? Im almost giving up...

This is a blast from the past! For me the problem was software. The early versions of the standard minim osd software didn't set the board to PAL properly, but any of the minimosd-extra builds of the last few years fixed that problem.

I also power my board just on 5v from the autopilot only. There are two solder pads on the underside of the board that you need to add a solder blob to, to make that work, but it means the board keeps a lot cooler.

Unfortunately not to everyone that blast from the past... i can still see recent posts regarding this issue, and mine is just another one one. Besides, in every single forum discussion about this, no one gives a solid answer.

I believe i tried everything! Feed from 5v, feed from 12v, feed from 5v with power module, feed from 12v using ubec, feed from 5v and 12v  using external psu, tried the reset which didn't worked of course. Tried all firmware vesions, and i can verify that the firmware changes the board to pal. My minim osd is working properly, only the video overlays the osd layer. To me, in my case its a hardware incompatibility. I could check that in last resource some people solved the problem by replacing the camera. Even saw one guy with a sony nex 5 that solved the problem by replacing the cable's video converter by a non sony one. Lucky others have solved the issue doing the "dance".

As i said, there is not one solution for everyone. I sent an e-mail to securitycam2000, seems that they know which cams are suitable for the job and not...

I agree it's a difficult issue to solve. Doesn't seem to be one particular solution that works for everyone. I'm not even sure the MAX chip is at the heart of it given how widely used it is.



Here we go again (with a solution)...with different set up, same issue. I loose video or my overlay when I plug in my gimbal. Heres my set up:

Primary Battery (6.0 4s) powers my power plant (Y6) and the minumOSD (5v side) via the APM 2.6

Secondary Battery (1.0 3s) powers my Gimbal, Video Tx and munumOSD (12v side) via the Vid Tx

I loose my overlay or video when my gimbal is plugged in. But I found hitting the reset button on the MinOSD fixes the issue every time. I even tried powering everything up in different sequences and it seems to work. I also want to NOTE that I loose video signal on my GoPro if I dont do anything for a couple of minutes, but if I hit record my video pops back up.

DO NOT connect a return wire from the osd back to the source. It confuses the video/osd....


Charles C Spencer III

James masterman said:

Ok, some more investigating reveals this - If I plug the output from a DVD player into the MinimOSD, I can see the OSD display over the top of it. Everything works as if it was in the plane. If I put the output from my Duo5800v2 rx into the MinimOSD, all I get is the video and no OSD. If I unplug the video, I can immediately see the OSD layer against a black background.

So the cause appears to be something in what the reciever is doing to the video output I guess. Or possibly the camera itself. The camera is a WDR700 from BEV RC (PAL camera). The resolution of these is quite high at 795x596, but close to a DVD.

Is the chip unable to manage resolutions this high? What is the resolution of the OSD itself? Are there only certain cameras that work with MinimOSD? If so, this needs to be made very clear when buying one.


If it is the receiver, does anyone know if it would be doing something special with the image? Don't they just output whatever the camera was outputing?


I'd really appreciate some help on this.Are there any MinimOSD gurus out there?




Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service