Hi all !

I need help about my MinimOSD freshly unpacked.

I've triple checked the cabling and I don't know why I've just a black image on my screen.
There is a suspicious comportement when I power on the system. I explain how it happens:
1. Connect correctly the Vin/Vout/RX/BLK between APM, MinimOSD and video transmitter 
2. Power on the APM 
3. Connect the battery balance connector 12V to the MinimOSD  

At point 2, the ST led (orange) blink and the D PWR (red) led power on and still.  
When I do the point 3, the ST led shut off and the A PWR led power on and still. 
After that, I just have a black screen... It's weird because the system worked at least once!  
The firmware is up to date and I use a XBee but I've not connected the TX port on the minimOSD.

What's wrong ? Someone can help me ?

Thanks in advance ;-)

Jerome

Views: 32203

Reply to This

Replies to This Discussion

Do you use the same battery for video and APM ?

Sadly I blow out two minimOSD, first one by don't knowing it, second one just accidently. If you use common ground on video and data input (and by using one battery you definitely do that) your minimOSD is dead.

There must be huge red letters in minimOSD wiki not to do this which can looks like normal thing like common ground.

Now I just want to know what exactly blows out, maybe diydrones can give some helpfull hand. I changed max chip, but still no picture, atmega works fine.

Thanks Vilnis !

Yes it's the same battery... It's saddly for these MinimOSD :(((

So the good way is to build the system like that ? https://code.google.com/p/arducam-osd/wiki/Customers_Setup

With a specific battery just for the VideoTX and the stage 2 of the MinimOSD ?

Yes, it's the way to go, seperate batteries. In fact, it's better for picture quality too.

But I "migrated"  to remzibi OSD loaded with minimOSD software from Hazy.

It looks like great !

Can you tell me more about your config ?

It's this one http://code.google.com/p/hazys-osd/

As I have one remzibi in shelf and just give it a try, and it works the same way as minimOSD. Now only thing is to somehow get current and rssi from APM2 to osd.

This is my first fly with this modified remzibi osd, looks it works ok.

http://www.youtube.com/watch?v=Oul9RsnW64E

Perfect !

I will try this soon !

Thanks for the help !

Hi, Do you mean that the MINIMOSD cannot be powered from the main battery and need it's own power source? Can I run it with a 2S pack?

Jerome, i am in the same situation than you. No video output on the minimOSD. I got this unit from jdrones but have been unable to get support from them.

 

Did you Have any  luck on resolving this?

 

 

Do you mean that the MINIMOSD cannot be powered from the main battery and need it's own power source? > Yes! You need a dedicated power source for the minimOSD and your FPV system.
Can I run it with a 2S pack? > No ! Because a 2S pack produce 7.4V and you need 12V.

Hi Patricio,

I'm sorry but I think your minimOSD is dead...
The documentation does not explain very well the danger while we use the main battery to power the minimOSD...

I got terrible results when running the minimosd and camera off its own 3s lipo pack (separate from the flight one). Lines down the image etc.

I'm running a 4s flight battery now, and use a buck converter (was $2 off ebay) to step down to 12v from the main battery and it works perfectly.

Really 12V?

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service