minimOSD no mavlink data. SR3 missing?

Hi new to DIY drones and ardupilot.

Im wondering if anyone else has had the same trouble as me or can direct me toward a suitable resource to help me out.

It goes like this:

Ive loaded up the latest version of arduplane to my apm2.6

ive flashed my minimosd with minimosd extra

ive connected the two (no telemetry radio)

all i get displaying from the OSD is No Mav Data.

after researching this i found that i have to set SR0 and SR3 parameters which can be found in the full parameter list.

i can find all the SR0 parameters but the SR3 is missing and seems to be replaced by SR1. so now i dont know what to set. i've tried treating SR1 as SR3 to no avail. i've alsoposted in the minimosd extra section with no conclusive result.

i hope this can help really looking forward to playing with arduplane. :)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I am having this issue too.  I followed all the setups steps correctly, Fyi, I have been using MultiWii for a year so I know how detailed you have be to make sure everything is right so everything works.  I have an Minim OSD loaded with MinimOSD Extra 2.4 (Plane).  I found a table with the correct SR0 and SR3 (now SR1) values and input them using advanced parameters in mission planner.  I hit "write", disconnected the USB cable and restarted my APM2.6.  I still only see "NO MAV DATA on my OSD.   Any ideas?

     

    • Anyone had success with this?

      I use MinimOSD with copter 3.1.4. Have done and redone the setup several times with no luck. My hud shows "No Mav Data" and then transitions to panel 1 with no updates showing.

      I use the Y splitter cable on APM 2.6 with the 433Mhz telemtry radio. Communication with mission planner is perfect with all telemetry data updating.

      • I had to revert to an older rev of firmware to get it to work. APM Plane 3.0.1 works on the plane side.

        • Interesting. Should this then be considered a regression in the newer firmware versions or does the setup work differently now.

          Would be good to have some clarity as whether this is truly "broken" for newer versions or if the documentation needs to be updated.

  • So I found that sr3 is now sr1, it was done to help tidy the naming up.

    As for my original problem it was due to me being connected to the PC during testing. via usb therefore using up the mav link port. Hence no mav link data could be written to the osd! Silly me.
    • how did you circumvent this issue? how did you write the mavlink data without usb cable?

      • You can write the parameter settings, and then pull the USB cable. As soon as the USB is pulled, that should cause the output to appear on the telemetry port instead of USB (the smaller PPM encoder CPU takes care of that).

        I'm not quite sure about 2 things though:

        1) Whether UART2 is still disabled in Ardupilot code on APM2 and

        2) Whether SR1 refers to UART0 over USB, UART0 over telemetry port, or UART2. Okay, it's probably not UART0 over USB, since SR0 is for that. So my suggestion - apart from looking the code if you can read that - is to try both SR0 and SR1, and look both at the telemetry port (always with USB pulled) and the UART2 port..

        • My issue turned out to be an APM:Plane 3.0.3 bug.  I reverted to 3.0.1 and everything worked as it should.  I reported the issue.  No idea if this will be fixed in the upcoming 3.0.4.

  • Hi,

    Go to initial setup, optional hardware, should see telemetry hit enable. Might help

    • I tried that.  It doesn't seem to be a button I can click.  I see it but seems shaded out and I can't click it.

This reply was deleted.

Activity

DIY Drones via Twitter
RT @chr1sa: My talk on PX4 and FAA certification is coming up at 1:45 PST today on the PX4 Dev Summit livestream. Includes some cool new st…
Tuesday
DIY Drones via Twitter
RT @seesharp: I'm tuned into the PX4 / Dronecode free live conference. Great stuff. Microsoft AirSim talk in 10 minutes. https://t.co/0zbZ2…
Monday
DIY Robocars via Twitter
RT @masato_ka: 距離センサを3つとESP32を付けたラジコンカーをDonkeyCarライクにNNで自動走行。3層FC極小モデルをTensorFlow Lite for microcontrollerで動かしてる。機体は借り物でRumiCarって言います。Tenso…
Monday
DIY Robocars via Twitter
RT @SmallpixelCar: My car was able to go all the way autonomously until the crosswalk. It was only 100 yards from the target. What should b…
Saturday
Liam left a comment on Agricultural UAVs
"Hi
I'm Liam from T-MOTOR. I would like to reach out to see if there is any possibility for us to work together.
We are a propulsion system manufacturer who offers motors, propellers and ESCs for all kinds of drone applications which vary from secur…"
Jun 30
DIY Robocars via Twitter
RT @SmallpixelCar: Smart move. The car used the shadow to guide it through the bridge. This was never in the training samples. But it learn…
Jun 30
DIY Robocars via Twitter
RT @SmallpixelCar: Getting closer to the target. Single camera. Untrained road. https://t.co/Wsr7RwDamj
Jun 29
Richard Cox left a comment on Australia
"Anyone in the DIYDRONES Australian subgroup based in Alice Springs, NT?
I am experimenting with Ardupilot (standard Arduplane), Pixhawk 4 FC in a 4-ch
RC "AXN Floater Jet" foamy plane..."
Jun 29
Omar Sykes left a comment on Australia
"Hi everyone, I am looking for someone who is good at drone building, repair and software in Adelaide. Please give me a call on 0477 319 219."
Jun 29
DIY Robocars via Twitter
RT @RoboticMasters: #donkeycar https://t.co/czuLoVRcA4
Jun 29
DIY Robocars via Twitter
https://t.co/DKQbNTbz0g
Jun 29
DIY Robocars via Twitter
RT @RoboticMasters: Donkey car, car car car car car car; Donkey car, car car car car car car; Donkey Car. Anyone like our tiny tiny donkey…
Jun 29
DIY Robocars via Twitter
RT @SmallpixelCar: After improving DBSCAN speed, I can get 11 frame per second on @NVIDIAEmbedded Jerson Xavier MAXN mode and the autonomou…
Jun 26
DIY Robocars via Twitter
RT @Heavy02011: Join us at next Virtual Race League: ⁦@diyrobocars⁩ Race #4 - Parking Lot Nerds, August 1st https://t.co/5KUpu7VGaH
Jun 25
DIY Robocars via Twitter
RT @SmallpixelCar: #CUDA implementation should be easy, because most of the time is on distance calculations berween two points and if the…
Jun 25
DIY Robocars via Twitter
RT @SmallpixelCar: This is the view from the car. Even my lanenet inference is fast on @NVIDIAEmbedded Jerson Xavier, DBSCAN clustering tak…
Jun 25
More…