Hi All,

I have two MinimOSDs that I'm having issues with.  I have them hooked up to an APM 2.5 and have split the telemetry wires to go to my 3DR radio and the MinimOSD (diagram attached.)  I can get video from the OSDs but one says UPDATE CHARSET and the other doesn't say anything.  Tried updating the firmware to V2 and updating the characterset but nothing works.  

Any idea what I'm doing wrong?

Thanks for your help,

Jimmy

Views: 1651

Attachments:

Reply to This

Replies to This Discussion

Its a known issue with a work around. Make sure the minimosd is powered on the 12v side in addition to the 5v it gets from the usb /ftdi side.

Thanks, mP1.  I have it powered as you suggested.  I didn't know that you have to have the GCS running to query the 3DR modem for it to received data so will try it that way tonight.  

The 12v is necessary because the charset flash wont update properly on many boards. You dont need the GCS. Its not a data issue. Having said that one of my minimosd wont flash even though im powering 12v. This trick did however fix another minimosd which wouldnt flash with just the ftdi/usb.

Thanks!  Will give that a try now.

That did it! Added a  BEC to regulate the power (9V) and plugged it in before trying to update the MinimOSD.  Updated it and put it in the plane, all's good.   Now just need to figure out how to setup up the APM to let me toggle between screens. 

Thanks again for your help. 

Jimmy

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service