MinimOSD V1.1 Problem, Black Screen, now trying to configure for crius aiop v2 using megapirateng 3.01 R4

I have been trying about everything, and if you search for this in a few days I think everyone will start flaming me for posting on about every discussion group I can find on the same discussion.

Personally I like finding my information on this Board so I will update my progress...


Successful flights with the MinimOSD v1.1 runing Minim OSD Extra 2.4, latest beta as of that date, no more freeze after arm, (connected to Pixhawk 3.1.5)


Installation of the same system on a Deadcat Frame, Crius aiop v2 Running Megapirateng 3.01 R4

(in checking versions for this post I noticed now there is a 3.1.5 R2 for the Crius... plan on flashing it, really hesitant however since the loiter function was flaky last flight, only alt hold, stabilize were proper, however think it was a mag sensor error due to a Ferraro Mag getting to close, will post after update)

upon power up interference on the screen, some horizontal dashes, mostly a gray screen, disconnected and then figured that the firmware was incompatible. 

Connected to computer, via FTDI cable (Yes I know to power from the Video Side, first, then 5v side then camera, the then camera seemed not as important on my setup) No I get video, then black/blank screen with a tiny bit of video maybe 3-4 lines on the bottom, flashes for a second to video, the blank, checked video feed, and I can get that fine, seems that the board works as if I re do my steps I can get it to:

load firmware

load character set

both will complete however during this time I do not see a boot on the fpv/video screen, just the same blank/black screen

I was able to hit rest during power up and noticed certain combinations such as the order of power could disable the black screen however I would not get a overlay.

I am suspecting I have a video chip problem on the minimosd v1.1 and trying to diagnose the problem.


Using a volt meter I checked the votage of both my ftdi cable and it was reading 5 v power, and 3.3 v tx rx;

At this point I had tried every other cobinations that I was able to get it to come to life before also see I posted on the steps prior, as I was having issues when it was new, and as the other post somewhere say the wiki is skinny.

I then tested the Crius inputs ( please not temerity is working, and gps, both of the first 2 serial ports, connecting the minim osd to the 3rd serial on the crius, tx to rx, ( this is well documented) however and should have testing this first the tx and rx voltages on the Crius AIOP v2 and as I suspected they are all 5.5.v

This is where I am confused, is this a firmware thing? immediately I remembered when I was connecting to the Pixhawk this:

TELEM1, TELEM2 ports

1 (red) VCC +5V
2 (blk) TX (OUT) +3.3V
3 (blk) RX (IN) +3.3V
4 (blk) CTS +3.3V
5 (blk) RTS +3.3V
6 (blk) GND GND

So is the V 1.1 fried by this seems strange as they seem to post that it is a 5v side and a 12v video side, I also have a colleague that has the same setup using a minim so I would not think this would do that...

So as of now I cannot get the minim OSD to post anything other than a almost full black screen or no overlay at all. the board will accept firmware and I can see it is booting, I suspect that the change in voltage may be in the firmware of both the minimosd and crius and possibly when I flash the crius to the 3.1.5 r2 it may change the voltage, (I have not dug into this and never thought these little boards had a programmable voltage controller)  


What do I need help with?

Does the MinimOSD v1.1 have a voltage regulation that messes it up if rx/tx from the board is greater than 3.3v? (Premise Pixhawk that worked with the same board and setup)

Anyone with this configuration with a Crius AIOP v2 please let me know if you have this working, which ports and what version of firmwares.

If it loads firmware, etc, and you get a black screen, can you recover from it? 

Is my board a goner? Seems strange that all the functions still work, as far as the board booting at least to either read value, save values (config or panels), load firmware and or character set.

Will be ordering a few more boards, but will not be connecting anyting to the Cirus until at least the voltages match the pixhawk I guess... seems like somethign that other would have documented if this is indeed the issue. 

Notes : What I hope is there is a way to rest the video chip, reprogram it, change a setting or do something as it seems that this is a common problem, happens often, and should have a fix, especially if everything else loads, it seems more like a setting thing 

Sometimes if you get a failed to connect to bootloader, do not try and read first, if nothing on the screen, try these steps...

Connect Video side, then computer ftdi, then first try and load a hex firmware, when done do not click it before you disconnect the usb to minimosd, then plug it back up, it should load, you then do the same method for the character... I can get confirmations on the computer, the video monitors shows a video feed and the black screens as noted above for me, however going though prior notes the responses in timing to load, and everything else suggests that I am booting just having a issue with the video overlay.

Views: 1742

Reply to This

Replies to This Discussion

In all my searching and review I think that my video chip just may be toast.., talk about temperamental and from what I experience is only a 3.3v chip and if a Rx tx line is greater it will black it out... Maybe a fix other than chip replacement however I have yet to find it...

Next I think the issue is the serial 1 port, which seemed obvious to use but I should have know to check everything to make sure it was the same first.

I have yet to check the Rx tx of the serials 2 and 3 but I suspect it will be a regulated 3.3 v

Seems to easy to screw up the minimosd... Maybe someone has a answer or a fix

Well, I have all but confirmed that the minimosd can be blown by a 5v connection on the Crius... Big Warning to all that try to connect.. I am hope I am the last however based on how easy it is to blow the Maxim Chip I think that there will be many more.. Goodbye little minim your were good

as long as I did not try and connect to you 5v for the rx tx.. but after you can be sued as a paper weight


Yep, it is probably toasted.

I had similar situation and biggest problem is that MAX is VERY sensitive to different voltage on digital and analog sides. So I solved it easy - bought one old V1 and solder blob there so both sides are powered from 5V rail which I have taken from one of ESC BEC. It looks working and so I am satisfied.

MAX chip is priced almost same price as Minim from China so it is better to order new one.

ok before I toast another Minim OSD I have a question, will it work with a Crius AIOP v2? 

I ask because If I check the voltages of the pixhawk output, they are right in line with the stated, however the crius? it bounces from 3.6v to 4.8v with the Pixhawk 5.5 and 3.3 as stated... My telemetry works fine which I can assume can handle this flux, however the max chip fried on me for the same voltage range... 

I may be skipping a OSD on a Crius if I cannot get confirmation

Yes, it will work as long as you keep same voltage level on both sides (which is problem on versions with different voltage regulator on analog side)


Indeed MAX7456 is sensitive to voltages differences between analog and digital part.

So, power minimosd from common 5V from FTDI is a good solution, with the two solder blobs.

BUT, whay do you say you have to use old V1 ? Why not V2 with the switching power regulator ? The swithing power regulator is not used if you don't connect any power 12V on the video connector.

Because there is/was lot of new ones without blobs joints on PCB. Yes, best is V2 with switching and blobs but in time of original post was problem to find them and some versions had switching but not easy way to interconnect. 

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service