MinimOSD won't show text when camera is plugged in, fine without

Hello. I have an APM 2.5 with MinimOSD. I can get my MinimOSD to function properly if my camera is unplugged. However, as soon as my camera is plugged in, I get great video, but no OSD text overlay. If I unplug my camera, me text comes back (with a grey screen behind it).

I've checked my cabling and everything appears in order.

I've reinstalled my firmware 2.0 and OSD Extra 2.1. I've also updated my character set. When the camera is off the OSD is functioning perfectly (no fuzzy or malformed text). It's like the OSD will transmit either the text or the video, but it won't overlay the text over the video.

I've also tried powering up the OSD is every possible order I can think of.

Any ideas?

Thanks!

Thomas

Views: 8531

Reply to This

Replies to This Discussion

Reid,

Thanks for your reply.

To help me understand your solution, you are powering both stages of the minimOSD from the 5V APM side. ie you soldered the jumper on the board?  Is the ground wire from the camera to the OSD board to the video TX?
Thanks for your help.

farmertom

Andrew,

Thanks for your reply.

So when you upload the character set you have a 12V supply connected to the board in addition to the FTDI cable?

thanks

farmertom

Andrew

I have just uploaded charset to the minim. I had a 12V supply plugged into the 2nd stage( video side as you call it). Now I have a great looking character set. However I am not getting video and the overlay. Just one or the other. the minim is getting info from the 3DR radio. I see all of the info updating.

I am stumped

thanks

farmertom

I found the answer!!!

First, I downgraded back to v1.9 and found it worked perfectly. Very interesting.

Next I published all the findings to:

http://code.google.com/p/arducam-osd/issues/detail?id=34

Gabor made some tweaks to the auto detecting code and sent me a beta to test. It worked! The formal fix will be in next arducam-osd release (which is the combination of arducam and minimosd-extra).

Until then, dropping back to 1.9 will get you back in the air.

The 1.9 release is located here:

http://code.google.com/p/arducam-osd/downloads/list?can=1&q=&am...

The 1.9 did not work for me. Same problem, no OSD when the cam is plugged in? 

I've tried Gopro hero 3 and some generic small cam that came with the TX.

Are you using shielded cable between camera and OSD?

I seem to have the same problem. I am not running shielded cabling. 

I found the problem. It's the 0.1 version. 

After getting the 1.1 version of the hardware, the problem is gone.

Don't buy the 0.1 version!

I have been having the same issues.  However if I plug my FPV camera in after powering the system up I get video and overlay.  If I power them together, just video. I found if I also unplug video out and plug it in the overlay comes up.  Using the reset button sometimes helps too. 

I am unsure what the problem could be?  As a short term fix I can plug the camera in after but I wonder if I could lose the overlay in flight.  I will try a RC video source switch to see if that helps get it back if lost. 

This helped me! I had the same problem; when the camera was connected, the text was not visible. However, when I tried wrapping the cable from the camera to the PSD in aluminium foil (the cable was originally unshielded), the text became visible. Weird! Is the signal "leakage" from the cable so great that it somehow dominates the system? Anyway, I'm happy that it works, I'll be updating to a shielded cable right away.

Did you guys ever figure this out? I just swapped fpv camera from fatshark 600tvl cmos to rmrc 420 ccd, and I lost all video overlay.

If I unplug the camera and replug it in, the OSD comes on very faintly. If i power cycle the entire multirotor, it will not show up again. 

I am not running a shielded cable, and I am powering the VTX side with 5v from immersion/fatshark VTX. But I never have before either.

Try hitting the reset on the minimosd after you powerup and if your having camera/minimosd problems. I cant remember the exact cause that problem fixed but its an easy thing to try and cant harm.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service