MinimOSD won't show text when camera is plugged in, fine without

Hello. I have an APM 2.5 with MinimOSD. I can get my MinimOSD to function properly if my camera is unplugged. However, as soon as my camera is plugged in, I get great video, but no OSD text overlay. If I unplug my camera, me text comes back (with a grey screen behind it).

I've checked my cabling and everything appears in order.

I've reinstalled my firmware 2.0 and OSD Extra 2.1. I've also updated my character set. When the camera is off the OSD is functioning perfectly (no fuzzy or malformed text). It's like the OSD will transmit either the text or the video, but it won't overlay the text over the video.

I've also tried powering up the OSD is every possible order I can think of.

Any ideas?

Thanks!

Thomas

Views: 8530

Reply to This

Replies to This Discussion

I have tried the reset button. No dice.

I have just tried a shielded cable. No luck there either.

I also have tried to change settings in the camera itself, baud rate and etc. no luck.

then I tried switching the minimosd to PAL from NTSC. No luck. switched back to NTSC.

Then I plugged in the old cmos camera (which I hate because its soooo sensitive to vibration), and voila. overlay works perfectly.  

Plug in the CCD camera, faint overlay, and if I power cycle the aircraft, no overlay. I have to unplug the camera and replug it in to get the overlay to come up....

any ideas? I'd really like to use this 480 line rmrc fpv ccd camera...

I have dug around all the settings in the camera... :(

I've had lots of weird problems with the MinimOSD, but they disappeared when I started using the 5V from the ardupilot to power both sides of the card. But I'm using a 12V 600 tvl camera...

Bah. I couldn't find a solid answer, so here's what I did.

I just put a switch in the power line between the fpv camera and minimosd. I just quick cycle the switch before flight, and voila.

Crude, but it works, and i'm flying. 

https://www.youtube.com/watch?v=Fus7MmZnSeY

Hey,

Any updates there?

Same thing happens with me.

Tried everything, but overlay with video works only if I replug power on camera (600TVL Sony HAD)

I'm having the same issue with my micro minimosd running MinimOSD Extra R800 on my large multirotor.  If I boot up with everything plugged in, no OSD.  As soon as I unplug and replug the camera, the OSD shows up perfectly.  Did you ever resolve, or just keep using the switch?  I thought about using a switch myself, but reverted to just plugging in the camera right before a flight (kinda annoying) instead.

I realize this is an old thread, but I thought I'd throw in my .02 as I just had this issue. I switched the minimosd to PAL and the problem resolved. The OSD and camera must both be in the same setting. Hope this helps someone. 

Here we are 3 years after the start of this thread, and the problem still exists!

I was using a 600tvl Sony camera with a 200mw vtx on a 210 mini quad, when I added a Minimosd micro. This was displaying fine until I started the motors, and the OSD disappeared! So to cure  this I bought an Echine 800tvl CCD camera and a small 600mw vtx. Connect it all up and I get no OSD display...unplug the camera from the Minimosd and the OSD displays perfectly on a grey background, plug the camera back in and the OSD is gone!

I have tried twisting the video cable, to no avail, and I have tried powering and grounding the OSD and camera from the same point, but still no luck. The camera is fixed NTSC, so I can't try it in PAL mode, but it seems the problem exists in both modes. No mater what I have tried so far I have not managed to get the video feed and OSD to display together.

Any new ideas out there????

 

You have tried toggling the OSD into PAL mode?
Yeah, I tried that. It still did not display with the video image, and when I disconnected the camera the osd was scrolling and illegible.
Are you using a micro minimosd? Not that this helps, but I have had lots of trouble with those little things burning out. My full size 3 yr old minimosd wrks great, lol. I have found a perfect 5v source is required for the micro to work well, I've ordered mine from Amazon. This sounds like a bummer of a problem.

Yeah, it is a micro minim osd which is perfect for a 210 size quad, if I can just get the bugger to work!

I've just ordered another cheap camera from ebay to have a play about with...this one is switchable from PAL / NTSC 

http://www.ebay.co.uk/itm/HD-700TVL-CCD-Mini-Security-Video-PCB-Boa...

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service