I just installed the update to MP 1.3.39 and realized that the Dataflash auto analysis is broken.

.bin files I could auto-analyze in the previous version of MP result in a "Failed to start LogAnalyzer" followed by a bad input file message wit this release.

I attached one of my .bin files in question

Any insights?

111.BIN

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Developer

    good to hear!!

  • @michael oborne I just upgraded to the 1.3.40 release and can report that Auto Analysis works fine again on Win32/x86.
    Thanks for fixing this!
  • Michael,

    I checked the release notes - I could not find any statements that the Auto Analyze function is all of a sudden no longer supported on x86 machines with version 1.3.39. I would appreciate if you could look into this - since it was working fine all the time before with the previous MP versions this should not be such big of a deal. Its certainly harder for us to purchase new hardware w/o prior notice....

    Thanks!
     
    Michael Oborne said:

    mp will run fine on x86 (joystick support requires this), the log analyzer will only run on x64 (due to memory issues).

    x86/32bit only supports 2gb of memory, and the analyzer uses a lot of memory.

    if you install python yourself you MAY be able to run the log analyzer however.

  • What is the error reported and maybe attach the logs here so we can see if we can reproduce the error.

    oh you said plane. sigh. no experience with the plane firmware but other do so maybe still do it.


    Kelly Foster said:

    I have had problems for months trying to auto-analyze data flash logs on MP, to the point of giving up. I run Windows 7 on a 64 bit Sony VAIO. I tried again yesterday using latest ArduPlane and latest MP and it failed yet again. Short session, smallish log file.

    Kelly
  • I have had problems for months trying to auto-analyze data flash logs on MP, to the point of giving up. I run Windows 7 on a 64 bit Sony VAIO. I tried again yesterday using latest ArduPlane and latest MP and it failed yet again. Short session, smallish log file.

    Kelly
  • Takes a while but it opens fine on my box

    Log File C:\Users\Craig\AppData\Local\Temp\tmpAC67.tmp.log
    Size (kb) 110111.673828125
    No of lines 1438418
    Duration 0:20:11
    Vehicletype ArduPlane
    Firmware Version V3.5.2
    Firmware Hash dc9d87fd
    Hardware Type
    Free Mem 0
    Skipped Lines 0

    Test: Autotune = NA -
    Test: Balance/Twist = NA -
    Test: Brownout = GOOD -
    Test: Compass = GOOD - mag_field interference within limits (11.23%)
    Max mag field length (703.92) > recommended (550.00)

    Test: Dupe Log Data = GOOD -
    Test: Empty = GOOD -
    Test: Event/Failsafe = GOOD -
    Test: GPS = GOOD -
    Test: IMU Mismatch = GOOD - (Mismatch: 0.58, WARN: 0.75, FAIL: 1.50)
    Test: Parameters = GOOD -
    Test: PM = NA -
    Test: Pitch/Roll = NA -
    Test: Thrust = NA -
    Test: VCC = GOOD -



    Jeremy Randle said:

    The file is uploaded here. Thanks for looking in to this.

    https://cloudstor.aarnet.edu.au/plus/index.php/s/VPYOKkgDsDgoXA4

  • The file is uploaded here. Thanks for looking in to this.

    https://cloudstor.aarnet.edu.au/plus/index.php/s/VPYOKkgDsDgoXA4

  • anywhere that is publicly accessible really.



    Jeremy Randle said:

    I just zipped it up and it is 22MB which is more than the 7MB limit. Should I put it on CloudStore or similar and post the link here ?

  • I just zipped it up and it is 22MB which is more than the 7MB limit. Should I put it on CloudStore or similar and post the link here ?

  • can you zip/rar the log and attach it to a reply so we can take a look at it?



    Jeremy Randle said:

    My computer runs an Intel Xeon E5-2630, 16Gb RAM and Windows 7 Pro 64Bit. The Auto Analysis fails on a 50Mb log from around a 25 min flight, with some non flying time before hand. Just tried it again and it killed MP, causing it to close.

    1) Is it best to run this on the BIN or the LOG as it seems to convert the BIN to a LOG before it can start anyway ?

    2) Is there anything I can do to make this work, or are the flights just to long ?

    Thanks

This reply was deleted.

Activity

xemone liked Max Gilson's profile
Aug 31
nick rymer left a comment on ArduCopter User Group
"I recently switched laptops and now have Windows 10. I installed Mission Planner on my laptop and plugged a mRo SiK Telemetry Radio into the USB port. The radio is not recognized on the com ports but is instead on the "Other Devices" tab in Device…"
Aug 20
More…