I'm sure I have had this problem a while back, but can't recall if it was a software bug or something else.

Anyhow, after updating Mission Planner to the latest update (1.3.9) it hangs if I perform a manual "CHECK FOR UPDATE" and if I load the INITIAL SETUP and INSTALL FIRMWARE, it displays the "There was an unexpected error" message.

Any ideas what the issue maybe.

MP is allowed through virus and firewall protection and displays the same error even if they are temporarily turned off.

Many thanks,


Views: 5879

Reply to This

Replies to This Discussion

Thanks Michael for your work on this. Everything appears good with the beta version even with .net 4.5.


         I am glad that Michael has solved the problem for you. I'm sorry but I'm a bit of a newbie on this site - can you please show me where is the link to the beta version so that I can solve my similar issue?



        Regarding the problems I had with Mission Planner 1.3.9 hanging on update and unable to download the firmware - I have just downloaded v1.3.10 and both problems have been solved - thanks.


Chris  sorry I did not pick up your request earlier. It was time for the new garage roof before the winter sets in. pleased to see you have resolved the matter.

Happy flying



Running Windows 8.1 with latest updates & trying to update MP 1.3.9 to 1.3.10. I noticed the following error in the application log after MP kept hanging

Log Name:      Application
Source:        Application Error
Date:          19/10/2014 7:54:40 AM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Surface01
Faulting application name: MissionPlanner.exe, version:, time stamp: 0x53f5302e
Faulting module name: clr.dll, version: 4.0.30319.34209, time stamp: 0x5348961e
Exception code: 0xc00000fd
Fault offset: 0x004226a2
Faulting process ID: 0x15a4
Faulting application start time: 0x01cfeb14a225ee10
Faulting application path: C:\Program Files (x86)\Mission Planner\MissionPlanner.exe
Faulting module path: C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr.dll
Report ID: f9d50e2f-5708-11e4-82e0-281878561640
Faulting package full name:
Faulting package-relative application ID:
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <TimeCreated SystemTime="2014-10-18T20:54:40.000000000Z" />
    <Security />
    <Data>C:\Program Files (x86)\Mission Planner\MissionPlanner.exe</Data>

Just wondering wether anyone else has had similar issues & how to rectify?

Thanks in advance

Hi Todd - Everything was resolved for me by loading the latest beta version of MP. I think MP v1.3.10. will also sort things out for you now.

Let us know


Thanks Richard,

Im just trying to run the upgrade through opening 1.3.9 first. Shall I just try a new download & install of 1.3.10 or can i manually download upgrade files?

Will I loose any data through this process (if there is any)


Just downloaded 1.3.10 mdi file & installed over the top of previous version after backing up log files. Worked perfectly :)

That's great - love it when it all come together. Happy flying.


Thanks Richard,

Mission Planner was what got me over the line to convert from DJI. Its just fantastic, Michael has done a great job.

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service