I have just joined DIY Drones and my son and I are doing things the hard way as we are trying to work things out as we go along.

We have mission planner and the APM 2.5 board

When we try and connect we get error messages saying "Cant open serial port"

We are on Windows 7 and have tried the same exercise on 2 PCs now with Windows 7

We have followed all the instructions but we are at a roadblock that seems to be doing its job very well.

I have searched the forum but I cant find anything that has helped us solve the issue.

We have reloaded drivers, ports, MP and so on.

If anyone has some advice we would love to hear from you.

We use our quad for general GoPro stuff on our outdoor activities but we were keen to get a little GPS control.

Our Youtube name is JBBunno if anyone is interested to have a look.

Thanks in advance

JB

Views: 8232

Reply to This

Replies to This Discussion

Update: I installed the lastest directX components and now I can see Com/LPT ports in the hardware profile

I can see com 1 and com 46 in the MP drop down

When I connect I get a time out then this error mesage.

"No heatBeat Packets recieved" (See attachment)

I sent an eamil to the supplier but they have not replied with any advice.

Attachments:

Did you get fixed yet John?Maybe a bit obvious but have you checked the baud rate is set a 115200 for the port, and you've tried both ports.

Here's another post that might be of help

MP problem

No good Martin

Just cant get MP to see the hardware, I contacted the seller and they want me to post back the component for testing to see If I have broken it???

Im over it already, I realy wanted this to work but stuffing around like this is very frustrating. There must be a better option than this, I just need to research it it better I guess.

Im not a brilliant flyer and I dont see me being as good as others as my prime hobby something else and all wanted was a stable platform to film from. I need a quad where, if I let go of the sticks it hovers and holds position. So naturally I thought this was a good idea. It seems I just cant get past go after spending 300 bucks $%^$#@....

I do appreciate everyones help and feedback though on this forum.

 

Just recieved a replacement MP, Plugged it in and guess what? It worked first time with no issues.

Pretty much thought i was going mad before I got a unit that worked.

I had since gone NASA and I have been having fun with that. But now I am keen to see what I can get going with Mission planner.

Thanks agin for all the input - who would have thought it just plain didnt work :)

Hello,

I am a newbie having the same issue that John describes.  I've got my first quadcopter assembled, I installed/uninstalled/reinstalled MP multiple times.  Downloaded and installed updates to directX and .Net framework,  through this process.  I've also installed both the Ardunio Mega and the FTDI drivers.  Still, I have never been able to get windows to recognize the APM plugged into my usb port as anything but an "unknown device."  Here is my setup:

- APM 2.5+

- 3dr Quadcopter kit (http://store.3drobotics.com/products/3dr-arducopter-quad-c-frame-kit-1)

- Spektrum DX8 with AR8000 receiver

- Windows 7

- MP 1.2.57 / Mav 1.0

- .Net Framework 4.0

- directX 10

When I power on the copter using a lipo, I hear 3 fast tones, 3 slow tones, and 3 fast tones and the props shake a bit.   The APM is showing me slow blinking red & blue lights.  I've bound the Dx8 to the AR8000, but I haven't been able to get the props to spin. I was hoping to use the MP to do some troubleshooting on the front.  I read something about arming the APM and I'm wondering if I haven't done that yet.

When I connect the USB to my win7 machine that is running MP, the blinking blue/red light turns to a solid red light.  With or without the lipo plugged in, I see the same solid red light on the APM.  Unfortunately my win7 machine never recognizes the APM as anything but an "unknown device."  I've tried uninstalling and reinstalling drivers (although windows doesn't recognize the Ardunio Mega 2560.inf as a driver), I've updated directX and my .net framework.

I'm at a loss.  Any suggestions would be greatly appriciated.

--Nate

Hello John
I'm a complete newbie just getting into the fpv hobby. I purchased the arduflyer 2.5 board and apon first boot, before soldering any pins I ran into the exact same issue you had. I totally understand your frustration for I have tried everything to get this thing to connect to the mission planner. I have read this forum completely desperately hoping for the fix but it would appear there is none. So before I breakdown and try to contact RC Timer I was wondering if you have learned anything more on the issue and possibly have any more ideas.
Thanks,

Matt

Matt they sent me a new APM and it worked - All that frigging around and the unit was faulty !!!
Made it almost impossible to work out since it was my first unit>

Anyways I got so frustrated with it I shelved it and went Naza,

Not saying its better cos I don't know - but its all working and easy to sort out.
Got some vids on Jbbunno youtube

Good luck

What company did you buy the APM from? I wondering how well RC Timer's customer service will be.

Yeah I was watching your videos. They look great!

I cant remember ,it was a link off this site.

Im not going back to APM unless I need something Naza cant give me.
Im not qualified to compare but I'm happy where I am right now.

Enjoy the ride its a steep learning curve but worth it.

Same problem.  Tried all the same and much more.. Any answers?

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service