Looks like after applying the May 14th firmware upgrade to my W8 Surface Pro Mission Planner is crashing. I ended up doing a system rollback before May 14th then upgraded with other updates EXCLUDING the firmware upgrade and things are fine.  When I Google the error in the logs the best thing that I could find was something about OpenGL and the Video Drivers. I'm attaching the log file in hopes that maybe some of the Dev's can check it out and lend a helping hand. 

If anyone else is running a Surface Pro for their GS, you might want to skip May's Firmware! 

Views: 1036

Attachments:

Reply to This

Replies to This Discussion

Hi Scott,

I have the same problem on my Surface Pro.

MissionPlanner and QGroundControl crash at startup.

Hey Oyvind,

Glad I'm not the only one! I noticed if you go into System Restore and roll back to a known good restore before the 14th things work fine. For now I'm going to turn off Windows Update and make sure I exclude that Firmware update moving forward until there's a fix. 

I installed the latest Intel HD Graphics 4000 display drivers (9.18.10.3071) - problem solved :-)

Alright confirmed fix on that. Installed the new 'firmware' and then installed the 9.18.10.3071 drivers AFTER the fimware update was installed. If you do it the other way around Microsoft clobbers the driver. 

Yup, this worked for me too!  I was freaking out that the last time I started the MP, everything was fine, and then nothing!  Thanks for posting the workaround.  Friggin' Microsoft!  ;-)

Just a FYI. Looks like Mission Planner was loading with the latest windows updates. Problem became when I tried to open files or save files. Mission planner would hang until you kill it. This driver fixes it:

https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=22605

New Surface Pro.

33 updates, including .net framework 4.5

Mission planner 1.2.61 will not install. Error message 'need to install .net framework 3.5', which would not install because 4.5 is installed.

3 weeks ago, Acer W3 also from MS store (same setup) loaded and ran the MP fine.

 

This morning, back to my trusty Dell Win 7 with MP 1.2.59 which has been running flawlessly, stopped recognizing the com port. This happened just after loading the latest MS critical update. Rolled back the win 7 update and back in business.

 

We may be seeing more than one problem here: Intel graphics, .net 4.5 comparability, ...

I guess 3DRobotics, which has the most invested in the MP software has to take the lead.

Wade

Thanks

Thanks!!!  I bought a new Microsoft Surface last night after my old Dell laptop finally died.. Did all the updates and got mission planner installed, worked fine untill I tried to load my parameter file and then just hung..

Found this thread after doing a google search..Installed it and now it works!! 

Thanks again..  :)

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service