Mission Planner does not connect to pixhawk: heart beat timeout


I am a high school junior and I am attempting to build an autonomous drone for my school project. I have little to no experience with drones, so I am only a beginner.

I am having problems connecting my pixhawk flight controller to Mission Planner on my PC. Whenever I connect, I get the "no heartbeat packet received" received error when mavlink attempts to connect to my pixhawk. 

Also, I had a successful connection to the pixhawk a few days back, and even today I can see the pixhawk detected under COM4 port, however, it refuses to connect. The pixhawk boots up fine and I am able to hear the successful boot up sound. I have tried restarting my computer, unplugging all peripherals, and trying multiple different USB ports/cables, but to no avail.

Any help/suggestions would be greatly appreciated!

Views: 1944

Reply to This

Replies to This Discussion

I read this article and connected my multimeter to my I2C port and received a voltage of 4.82 V. This is larger than what they said was normal in the article (+-3.3V). So the voltage regulator could be fried, or maybe this article does not apply to my case because it is based off of the APM and not the pixhawk.


I assume you have the Pixhawk driver installed?

Yes, I have the driver installed. I recently even talked with 3dr's technical support with no avail. I have tried different USB ports, different computer, uninstalling/reinstalling the Mission Planner, connecting without GPS/all peripherals, and checking if the sd card was inserted properly.

I think I am going to purchase a new pixhawk and return the one I have now as it seems like there may be a hardware defect or something.

So, can you load firmware on the unit?  What have you loaded so far?  Without firmware running on the unit there will be no Mavlink heartbeats being sent and your computer will have nothing to talk too.

If you are getting good sounds when it starts up then the firmware must be not installed correctly.

Yes I have APM Copter loaded on the unit. MP can detect the firmware as well.

Well that would indicate the board is working.  What version of ArduCopter did you load?


APM:Copter V3.4.6 Quad

In Mission Planner in the pull down list of com ports it says: COMX PX4 FMU (COMX). baud is 115200.

On the Pixhawk you have yellow flashing led in the middle and the back 5 LED's has two yellow led's on and on the left one blue led flashing?

The port and baud rate are set as you said. The center led is yellow solid not flashing. The other lights look are as you said. When it starts up I hear a long beep.

That's not good.  Is it one of these sounds?  http://ardupilot.org/copter/docs/common-sounds-pixhawkpx4.html

I think it is the "armed" sound.

Check that the SD card is properly inserted and if you have a computer make sure that you can see files on it.

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service