Mission Planner does not connect to pixhawk: heart beat timeout


I am a high school junior and I am attempting to build an autonomous drone for my school project. I have little to no experience with drones, so I am only a beginner.

I am having problems connecting my pixhawk flight controller to Mission Planner on my PC. Whenever I connect, I get the "no heartbeat packet received" received error when mavlink attempts to connect to my pixhawk. 

Also, I had a successful connection to the pixhawk a few days back, and even today I can see the pixhawk detected under COM4 port, however, it refuses to connect. The pixhawk boots up fine and I am able to hear the successful boot up sound. I have tried restarting my computer, unplugging all peripherals, and trying multiple different USB ports/cables, but to no avail.

Any help/suggestions would be greatly appreciated!

Views: 1944

Reply to This

Replies to This Discussion

I can see files on the sd card and I am pretty sure that it is properly inserted. There are two folders, Log and Terrain on the card. Log does not have anything in it. Terrain has some .DAT files in it.

I'm at a lose than.  It would seem the unit is defective.  Maybe a developer could point to the error sound that the unit is making and determine what might be wrong.


the fix for me was to load rover then back to tailsitter,he also fixed every thing else I could think of, amazing skill set, thank you Tridge...... this fixed my pixhawk, the explanation in duel motor tailsitters. 

The same problem, Solved by formatting the SD card.

I had the same issue. REsolved by connecting the Ground unit to laptop using FTDI. Then load settings in mission planner, as you would normally do with the air unit.
Untick ECC & Op Resend. Save settings & try again.

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service