Mission Planner Install on Windows 8

Hi all, just starting out with all of this so forgive me if I've missed a post that already covered my issues...

 

I've been a mac user for years, and just picked up a small acer laptop running windows 8. I've been trying to install the Mission Planner for a couple of hours now, and it won't go. The installer runs most of the way through, then the progress bar runs backwards and it says it encountered an error. The really irritating bit, is that it doesn't specify what the error is.

 

Things I've already tried:

I have installed the latest .net 4.5 framework, which just returns a prompt stating that it's already there. I tried to install 3.5 as well as I read a reply on another post that said that the two can co-exist. When I run the installer for 3.5 I get the prompt that asks for permission to alter the comp etc, but after that nothing happens.

 

I have also followed the steps outlined here:

http://diydrones.com/forum/topics/how-to-windows-8-mission-planner-arduino-drivers?commentId=705844%3AComment%3A1021567&xg_source=activity

although as I currently understand it, this should only affect the ability to communicate with the APM once Mission Planner is running.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • After following the steps you referenced I was able to get the driver installed however I'm still having one problem and was wondering if anyone else is?

     

    When I try to load the parameters for a Bixler I hit the Load button from the Config screen and the Mission Planner freezes.  I have to go into the Task Manager to shut the program.  I don't ever get the new window that asks where the parameter file is located.

     

    On my Win 7 machine the operation acts as expected and I'm able to load up the parameter file but I'm curious if anyone else is seeing this behavior in Windows 8?

     

    -Mike

  • Developer

    i just uploaded a new msi that should install drivers and mission planner without any problems on windows 8

  • UPDATE:

    I just downloaded version 1.2.18 of the mission planner, released earlier today, and it installs perfectly on my Win 8 machine. I've tested it by connecting via usb and 3DR telemetry, both work as usual. 

    It would be really great if someone that hasn't done any of the previously mentioned steps would try installing it and let us know if it worked. Or if you still have to do the drivers and .net etc...

    Thanks to Michael Oborne for getting the update out.

  • It appears you have found a solution for now, but did you try running the installer as an administrator?

    • Right click the installer and select "Run as administrator.."
  • I tried connecting W8 to my APM and gave up. Ended up reverting back to W7. From what I can tell Mission Planner tries to install the drivers needed to talk to the APM and dies from there. Could it be because the drivers are not signed? Either way I noticed if I copied Mission Planner from one computer to the W8 machine I could just double click the icon and it'd work. However because the drivers for APM were not installed I couldn't upload a mission. Again dead in the water...

    I'm personally holding off on W8 until some more development work can be done. Not only for Mission Planner but for some other applications I use on a daily basis. I'd just be nice to have Mission Planner and the APM working before the Surface Pro comes out. That tablet is a Intel based processor and runs 'normal Windows apps'. It'd make a awesome portable ground station! 

This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…