Mission Planner Mavlink Won't Connect (No Heatbeat Packets Received)

MP connected and downloaded firmware to the APM 2.5 without issue.  But when I click the upper right Connect to get the parameters:

o When the USB is plugged in, COM4 Adrino Mega 2560 (COM4) appears [device setting is 115200 as is the MP pulldown]

o When click Connect

   - MP sees the connection and it starts to connect

  -  APM blue light 3 times, red flashes twice, yellow light flashes, green is solid 

o Then countdown to "No Heatbeat Packets Received"

  - orange light stops

  - green stays solid

o Under details, the following is shown.

I might be just tired, but can anyone help?

I'm powering via the USB.  Nothing but the GPS/Mag and radio is powered by the APM (disconnected the receiver and ESCs).  I've tried adding battery power, reinstalling the firmware (does that part just fine), differnt USB ports, restarting my computer, ... 

Views: 15383

Reply to This

Replies to This Discussion

I'm stumped. I'd try telemetry, but the situation does not sound good. Have you used the receiver on anything else since? Maybe it caused a short..

Thanks for the input, both Hugues and Ted and confirmation that my newbness is at least troubleshooting in the right direction.

For some reason I cant get any measurements off the 2 pins directly off the vertical I2C plug

But when I measure across the regulators lower and upper pins I get 5.1 volts

Forgot to mention that the signature initial blinks followed by the no blink brown out also happens

So there we have it thanks for confirming it.

Did try another USB cable, reboots, reinstalls EEPROM erase all to no avail, it was only after seeing theclosed post and this one by Forrest that my understanding gelled and put the voltmeter leads to the board.

The boards vendors site clearly states they have done the needfull and added the 100uF Cap mod to avoid this so im stumped

Contingency to get back on track Fast as Possible located supplier here under $10 shipped 1-2 days hoping seller will step up but that will likely entail a 20 day wait

Plan C

If im going to wait is it circuit board roulette buying an APM board from sources like GOODLUCKBUY et al ?

Good decision to fly pixhawk, you'll get all the benefits of the next release 3.2 and you will get redundancy: power, sensors, etc

we are trying to do that. I will tell you more soon

Did you ever find a solution to this? Did you receive a replacement?
Did reflashing the ppm encoder work? Doing this is my final test unless 3DRobotics responds with something else.

Not sure I've ever troubleshooted a hardware connectivity issue more.


I have same problem.

MP 1.3.3 Build 1.1.5256.36415, Win 8.0 ugh
Can connect with 3DR telemetry radio fine.
Cannot connect using USB with radio disconnected.
Tried several cables, USB ports, re-booting with no connect.
APM 2.6 shows power. Worked with a previous MP version, but I do not recall which one.

Trying Auto connect at default baud rate of 115,200 yields error: "Timeout waiting for Autoscan…" and sometimes the window grays out.

Trying "Mega" port at various baud rates yields timeout " No heartbeat…"

Any and all help appreciated.

Can you configure sensors with the telemetry radio? If so, do you get a compass orientation?  

I found that my compass was never providing an orientation.   I tested voltage at the l2c port and found next to no voltage coming through.  Power source of usb was definitely not the cause. 


Thanks GregM.  Problem went away in a weird way.  Shut down computer last night with nothing working, started computer in morning and USB works.  I did absolutely nothing to change the situation.  

Good to hear. Have fun!

worked with the techs.  they said to return it.  did so just prior to sailing the Bay of Biscay and Atlantic off the coast of spain.  will see if the replacement works when i get back in June.

Yea, they are going to replace mine. Just shipped it back.

I'm a little disappointed you would prefer sailing off the coast of Spain than fix your drone.  Where are your priorities?  ;) 



OK have a the fixed board in hand.

I must step up and ask the el grande stupido question of the week....possibly the year

But in more than one location on credible sites and so on it says

"When connecting to USB, do NOT have anything else connected to the board nor Do not connect any devices such as a radio receiver, MinimOSD, GPS, etc while the APM is powered especially while powered only through the USB cable. Doing so could damage the board, this is now minimized with the SMD 3.3V regulator MOD, but best to play it safe and provide the addtional external power, and no connecting anything while powered.."


How is one supposed to for example hook up and calibrate GPS and setup anu other hardware for that matter?

The repaired board does have the 100uf cap mod to protect against this but its really confusing.





Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service