Hello Everyone,


Ok I have a challenge that does not make any sense.  I connect my APM 2.5 to the PC and start the mission planner and it claims they are connected BUT I am getting zero readings off the quad with the data or config tabs.  No GPS no compass, no radio controls yet if I go into the terminal settings and test the gps or compass it reads it just fine.


It allowed me to download and install 2.9.1b but still nothing.  On Top of that all of my motors are beeping like they are not calibrated.


First I thought it was a radio connection but the board will allow me to arm with the controller.


This is very frustrating any help would be awesome.






Views: 419

Reply to This

Replies to This Discussion

I am having the same problem.

After many hours of troubleshooting this, I discovered that if I install FW version 2.6 I can get Mission Planner to work. Though I now have an issue with the altitude on the HUD display. It read -21438760 meters. Still haven't figured this one out.

I've contacted 3DR but they have not responded yet. I'm beginning to believe that there is a problem with the APM2.5.

I am curious to know if you install FW 2.6 if it work for you.




sorry to hear your having the same problem as I am having.  What is weird is I must have at least 40 flights on this board.

As for FW 2.6 I was using 2.8 at the time this happened then upgraded to 2.91b to see if that fixed the problem but no.  I will try the 2.6 and see if that works but that can not be the real solution.


Please let me know if 3DR responds to you.




My APM worked less than a day with the 2.9.1b release.

I spoke with 3DR today and according to the person I spoke with they are currently working a similar issue with another user. 3DR said there is a 90 day warranty on the APM and was going to RMA it but since I purchased it through UAV-America I have to return it to them for replacement. I contact UAV-America and Jim will send me a new APM as soon as he receives the old one.

In the meantime I had ordered another APM for my hex copter. It arrived today so I will install it this evening and see how that goes. Stay tuned!

Do you have a 3DR Telemetry radio connected as the same you plug the USB from the PC into the AMP?  If so, try unhooking it.


Sorry I'm not sure what you mean. Are you asking if I have the 3DR Telemetry radio plugged into the same USB port as the USB cable for the APM? If so yes I'm using the same USB port but I have only one (3DR or USB port from the APM) connected at a time.


At should have said "at the same time" instead of "as the same".  I've had problems connecting to the PC with the USB port while the 3DR Telemetry module was also connected to the APM.  I just unhook the Telemetry module and it all has worked fine for me.  Sorry for the confusion, typed too fast  ;)


I installed and configured the second APM I had ordered and it is working perfectly. This just proves what I already suspected, the first APM is defective.


No I have not figured it out. 2 brand new APM's one works with 2.9.1b and the other works with 2.6. I'm guessing there may be some circuit board revision issue. But this doesn't explain why Jason's worked on 2.8  and does not on 2.9.1b.

Are you experiencing the same problem?



I have also ordered a 2nd board but I can not get this board to connect to APM at all not even terminal.  I can not get this board to power up with a battery either.


Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service