I have been trying to get the Mission Planner to accept UDP and TCP/IP inputs.

I keep getting a time out error on a UDP  connection.  I have tried various playback rates and real-time rates, but I always get a time out error.

Is there anything special with UDP and TCP/IP connections?



Views: 5157

Reply to This

Replies to This Discussion

Hi warren, I have the same problem now did you manage to solve it?


I am thinking about just adding another receiver.

That should be an easy way to bypass the problem.

both tcp and udp should work. it is required to be 2 way however.

Do you have some example code?

How do you do a two way on UDP?

I'm using the wifly module connected to my board (crius aiop), the wifly and my pc are connected to a router, mission planner is seeing the udp connection but can't load the configuration, I get connection time out, I think I'm having a problem with port numbers.

MP replies to the same ip/port that the packet originates from.

I'm having this problem know that I can't get over, when i try to connect I get this message " getting params(sysid 1,compid1)--> the first image, and the the second message comes up --> the second image,i have set the MP to listen to port 2000 the same that my wifi module transmit on, and i have set the correct baudrate on my wifi module according to the serial on my board ( crius aiop 1.1 flashed with MPNG 3.01 r4), i don't know whats causing this problem.


please use something like wireshark to see what is going on.

I solved my problem, it seems that there is a problem in megapirotng 3.01 r4 serial 2 and 0, when i flashed my board with the mpng 2.8 r3, the connection was established successfully using tcp connection.

Hello. I'm on a similar project. Which tcp port did you use to connect to it? Have you tried UDP port 14550? Thanks in advance.

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service