Hi.
When i armed the pixhawk to run, i move throttle stick to up small movment, motors start to spin and rpm increase without any control . Motor spin is very fast in stabilize mode and indoor witht prop on motors. THR_MIN default 130 and MOT_SPIN_ARMED default 70. What is the problem. I use arducopter 3.3, opto esc and Attoplito 180A, 6S 10000MAH. I use second power for pixhawk via ubec 5v. Thanks..

Views: 830

Reply to This

Replies to This Discussion

What Kv motors?

Sunnysky V4010-14 375kv. and Foxtech Multi-Pal 40A OPTO ESC(Simonk Firmware)..

I've seen in this situation that the rpm will increase as the Pixhawk expecting vertical movement but without props on nothing happens so it requests more throttle causing rpm to increase, etc. Not sure if this is your case, I suppose the only way to check is to try with props on, outside, somewhere safe having made sure the setup is 100%.

Okey, thanks a lot.

I do this with all my maiden or re-maiden flights:

On short grass/lawn, in an open area, carefully throttle up to about 25-35% so the quad is just starting to "get light on the skids". Now try to pitch forward gently, you should hear and see the rear two motors speed up and the front two slow down. Same for right roll - right motors slow down, left motors speed up. If this doesn't work exactly like this then something is wrong so don't try take off!

I couldn't see spin problem without pron on motors. I find this fast spin problem while compassmot on balcony of my home. I will try outside. Maybe this problem solve. But first of all I will recalibrate esc and rc calibration then I will test outside. I had a naza but I sold it four monts ago. I bought pixhawk for autonom fly. Hopefully, I can do it..

Hi again. I loaded old firemware 3.2.1 and I have  done all setup (rc, esc calibration, failsafe, accell calibration, battery...)I tested no prop on ground. They are very good motor spin. No problem. Then, I loaded new firemware 3.3.3 copter and Mission Planner 1.3.37. I have done all setup and tested no prop on ground. Some motors increase spin and amper level more and more on mission planner screen. And I have taked my vehicle, and start spinning the motors, then tilt the vehicle around by hand in my home. No problem. Motors spin normal level.I have seen amper level normal on mission planner normal. WHY.. Maybe EKF.. Thanks.. Sorry for my bad english..

Firstly, you should never do Compass Motor calibration without the props!  This calibration requires the motors to pull lots of amps like it does in flight.  Without props the amps will be very low and the calibration will be inaccurate.  Flip the props upside-down and change CW with CCW and vice versa.  Copter will now push down into the ground when doing compassmot calibration.  Be sure your landing gear are strong enough!

The motor spinning faster and faster sounds normal without props.  Really cannot diagnose issues with copters without flying them.  As long as the motors spin the right direction you are ready to test fly.

Thanks..very thanks..

I took an old office swivel chair and removed the back and seat and screwed on a 60cmx50cm board on it to use as a mobile work stand for working on copters. This is also good to tie down your copter to and test the motors on. You can easily see it tilting and rotating to check if its behaving correctly.

Attachments:

good combination..I am testing by my hand no prop.

Last test is compassmot. Than I will fily. I am doing case for my hexa.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service