Hi guys. This morning I had to reconfigure my F550. I needed the 40a 6S capable esc it had for a future Y6 build.

I just swapped them for rctimer 30A 4S opto esc I had from another build. The motors are rctimers hp2217-930kv with 10x3.8 props so all should had been ok running at 4S.

Unfortunately, motor number 1 stalled in mid air. For the first seconds it was like nothing had happen. 

After that initial seconds things happened so fast that I don't remember actually what I did but I do remember the hexa started spinning ( i think clock wise ) tilted on its axis and it came down. sigh.

I was prepping for a autotune session. Just wanted to see before if it was flyable ( it was ) LOL.

After crash, on the bench, I immediately reproduced motor 1 problem. It really looked like a sync problem. Stupid me for not trial testing before but It was not new esc or motors. Both have been running ok, just not together. I didn't see any reason at the time for it.

Moving along, I tried to adjust blheli 14.0 settings , pwm vs damped light ,motor timming, demag, etc. I could always make it literally stall no matter what. In last resort I swapped esc from other arm and problem solved.

Just to be sure these motors/esc were not "incompatible" , I retested this time the "bad esc" with another motor and yes, same problem, different motor.

These 30A esc worked ok on other builds, they just had different motors.. 

I tried my best to make the remaining 5 esc/motors stutter or stall but they worked perfectly. 

I just need to replace the "failed" esc. It probably has just that little bad matched mosfets and with this motor combo the mismatch showed itself.

Life goes on..sorry for the long story.

Now, I really wanted advice from you fellow pilots. What could have I done to bring it down not so hard??? I had 5 motors, sufficient thrust and battery. I think I gave it throttle but I don't recall seeing the copter responding to my controls, any of them actually.

But I do recall perfectly seeing it hover without motor 1 for some small time!

Should have I put it in loiter and go from there ?? If it managed to kinda hover It would have gave me some time to think..

More importantly. Would the hexa in Y6 config have fallen the same way ? 

Anyone with some advice ??

Thank you.

Log attached for the interested.

Views: 309

Attachments:

Reply to This

Replies to This Discussion

with 6 motors i heard you are suppose to be able to fly if you lose one...well, mine didnt when one motor failed....it flew for while but eventually hit ground kinda hard, thou not as hard as if it had totally died on all motors....

it depends on the weight, wind, etc.....

I think the issue is magnetization of motor stators. This happens with certain make/brand of motors. There is no ESC sync issue. I spent 3 months last year on this issue. motors with high poles get magnetized generally after 10 mins of flight. then they loose power. I had this issue with T-motos 3508-580. once I replaced the motors with another make the issue got resolved. And this does not happens in all the flights. I am very sure AC3.2.1 has nothing to do with sudden stalling of motors. but do remember to provide independent ground to each ESC along with signal wire. I have some very cheap motors that are flying very well for last two years on AC3.1.5 and AC3.2.1. if the crash happens after a couple of minutes into the flight then it should be magnetization issue.

I understand the magnetization but these motors had fly several times just with different esc and I just was not able to make the remaining 5 motors/esc show any kind of problems. Only that single esc showed problems with these motors.
How tha hell are some YouTube users able to at least maintain hover and with some luck bring it down safely? Mine started spinning tilted and down she came. The spinning part is what confuses me.

BLHeli firmware on my ESCs does have a setting for "demag" of the motors.....its on by default i think....

It does and I did all possible combinations. That particular esc has some problem unfortunately.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service