Hey folks,

I'm in the process of building my first quad.  I've been flying RC for just over six years, so I'm fairly well acquainted with most everything involved with a quad - save the FC.  I'm in the home-stretch and need some input from the experts here.

I've got everything mounted and the ESC's calibrated.  However I'm currently stumped on getting motor #3 to respond to the motors command.  The other three respond in the correct order (1, 4, 2), but then it skips three.  Motor #3 will run up correctly when the system is armed.  All 4 ESCs are matched Innov8tive Next Level 20A controllers, flashed with SimonK.

Here's what I've tried so far:

  • Moving the motor ESC connectors to different ports on the APM 2.5 board - still skips the same motor
  • Tried each ESC in motor position #1 for motors command.  1,4,2 all respond correctly.

I've also mounted the quad in a test-jig, and all four motors appear to run up just fine.  Inputs from my radio cause the quad to pull in the correct directions (roll, pitch, yaw, lift), but I'm hesitant to try free-flight without everything checking out correctly.

I've uploaded the following quick video to youtube:

http://youtu.be/xbEDRaGexfE

So what do you think I've missed / misconfigured?  

Thanks in advance!

Views: 279

Reply to This

Replies to This Discussion

One last "bump" to see if anyone has any good ideas.

thanks,

-Brian

I have the same problem...

Have you tried to maiden your multi yet?

I tried mine in a test harness, and it can get to a stable hover.  So I'm thinking I'm going to take mine out this weekend for a full-on maiden.

No. I didn't finish the build yet...

Okay, so I maidened the quad. Flies pretty well, however it does want to wander towards that motor on takeoff. I'm going to spend a few days to see if I can get it tuned in on loiter. If it continues, I may replace the #3 ESC.

Hi Brian,

Please see http://www.diydrones.com/forum/topics/apm-2-5-motor-setup-only-one-....

This is the thread I opened and there is tow nicely guys helping me out. 

I hope it will be helpful to you too.  

Just to close things out, I managed to fix my problem.  I had to recalibrate the #3 ESC.  Due to how my bird was built, I had to disassemble it to get to my ESCs.  

This speaks well to the ability of the APM board and ver 2.8.1 of the firmware.  I had multiple flights even with the mis-calibrated ESC.

Flew two packs through it today in 5-15 mpg gusts, very stable.

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service