I have been trying to get the latest 1.2.82 MP to run on my RaspberryPi.  Here is what I have and tried:

pi@raspberrypi ~/mp-1.2.82 $ cat /etc/issue
Raspbian GNU/Linux 7 \n \l

pi@raspberrypi ~/mp-1.2.82 $ uname -a
Linux raspberrypi 3.6.11+ #538 PREEMPT Fri Aug 30 20:42:08 BST 2013 armv6l GNU/Linux

pi@raspberrypi ~/mp-1.2.82 $ cat version.txt
1.1.5033.11289

pi@raspberrypi ~/mp-1.2.82 $ mono MissionPlanner.exe

Unhandled Exception: System.TypeLoadException: A type load exception has occurred.
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeLoadException: A type load exception has occurred.


pi@raspberrypi ~/mp-1.2.82 $ mono ArdupilotMegaPlanner10.exe
     error window pops up:
            No such file or directory

Mono was installed with "apt-get install mono-complete" after an update and upgrade.

How can I figure out what file is missing?  Is there a debug that I can turn on to show the steps mono is taking or a log file to check?

TIA,

Rick

Views: 573

Reply to This

Replies to This Discussion

rename mavlink.dll to MAVLink.dll

Still errors out.

pi@raspberrypi ~/mp-1.2.82 $ ln Mavlink.dll MAVLink.dll

pi@raspberrypi ~/mp-1.2.82 $ mono ArdupilotMegaPlanner10.exe
     error window pops up:
            No such file or directory

pi@raspberrypi ~/mp-1.2.82 $ mono MissionPlanner.exe
If your error is about Microsoft.DirectX.DirectInput, please install the latest directx redist from here http://www.microsoft.com/en-us/download/details.aspx?id=35


Stacktrace:

at System.Drawing.Font.CreateFont (string,single,System.Drawing.FontStyle,System.Drawing.GraphicsUnit,byte,bool) <0x00147>
at System.Drawing.Font..ctor (string,single,System.Drawing.FontStyle,System.Drawing.GraphicsUnit,byte,bool) <0x0007f>
at System.Drawing.Font..ctor (string,single,string) <0x00057>
at (wrapper remoting-invoke-with-check) System.Drawing.Font..ctor (string,single,string) <0xffffffff>
at System.Drawing.SystemFonts.get_DefaultFont () <0x0007b>
at System.Windows.Forms.Theme..ctor () <0x00033>
at System.Windows.Forms.ThemeWin32Classic..ctor () <0x00013>
at System.Windows.Forms.ThemeVisualStyles..ctor () <0x00013>
at System.Windows.Forms.ThemeEngine..cctor () <0x00083>
at (wrapper runtime-invoke) object.runtime_invoke_void (object,intptr,intptr,intptr) <0xffffffff>
at System.Windows.Forms.X11DesktopColors..cctor () <0x000bb>
at (wrapper runtime-invoke) object.runtime_invoke_void (object,intptr,intptr,intptr) <0xffffffff>
at System.Windows.Forms.XplatUIX11..ctor () <0x001c3>
at System.Windows.Forms.XplatUIX11.GetInstance () <0x00077>
at System.Windows.Forms.XplatUI..cctor () <0x0015b>
at (wrapper runtime-invoke) object.runtime_invoke_void (object,intptr,intptr,intptr) <0xffffffff>
at System.Windows.Forms.Application.EnableVisualStyles () <0x00023>
at MissionPlanner.Program.Main (string[]) <0x00047>
at (wrapper runtime-invoke) <Module>.runtime_invoke_void_object (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:


Debug info from gdb:

Cannot access memory at address 0x0
Cannot access memory at address 0x0
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/arm-linux-gnueabihf/libthread_db.so.1".
[New Thread 0xb57ea460 (LWP 27287)]
[New Thread 0xb58ea460 (LWP 27286)]
[New Thread 0xb672d460 (LWP 27285)]
0xb6e417d0 in read () from /lib/arm-linux-gnueabihf/libpthread.so.0
Id Target Id Frame
4 Thread 0xb672d460 (LWP 27285) "mono" 0xb6e40700 in sem_wait@@GLIBC_2.4 () from /lib/arm-linux-gnueabihf/libpthread.so.0
3 Thread 0xb58ea460 (LWP 27286) "mono" 0xb6d982e4 in read () from /lib/arm-linux-gnueabihf/libc.so.6
2 Thread 0xb57ea460 (LWP 27287) "mono" 0xb6e3e494 in pthread_cond_wait@@GLIBC_2.4 () from /lib/arm-linux-gnueabihf/libpthread.so.0
* 1 Thread 0xb6f15000 (LWP 27284) "mono" 0xb6e417d0 in read () from /lib/arm-linux-gnueabihf/libpthread.so.0

Thread 4 (Thread 0xb672d460 (LWP 27285)):
#0 0xb6e40700 in sem_wait@@GLIBC_2.4 () from /lib/arm-linux-gnueabihf/libpthread.so.0
#1 0x00195a40 in mono_sem_wait ()
#2 0x000ea384 in ?? ()
#3 0x000ea384 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 3 (Thread 0xb58ea460 (LWP 27286)):
#0 0xb6d982e4 in read () from /lib/arm-linux-gnueabihf/libc.so.6
#1 0xb58f1aec in ?? ()
#2 0xb58f1aec in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 2 (Thread 0xb57ea460 (LWP 27287)):
#0 0xb6e3e494 in pthread_cond_wait@@GLIBC_2.4 () from /lib/arm-linux-gnueabihf/libpthread.so.0
#1 0x0017cbe4 in ?? ()
#2 0x0017cbe4 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0xb6f15000 (LWP 27284)):
#0 0xb6e417d0 in read () from /lib/arm-linux-gnueabihf/libpthread.so.0
#1 0xb6e41044 in __pthread_enable_asynccancel () from /lib/arm-linux-gnueabihf/libpthread.so.0
#2 0x00096e60 in ?? ()
#3 0x00096e60 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Aborted
pi@raspberrypi ~/mp-1.2.82 $

Also tried with :

    ln Mavlink.pdb MAVLink.pdb

Should I be running mono on MissionPlanner.exe or ArdupilotMegaPlanner10.exe ?

Rick

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service