I'd like to fly more than one emulated drone simultaneously. The website says that I can fly "unlimited multi-drones", which I would like to think includes emulated ones (as they are important to avoid later collisions between multiple drones in the real-world!).

The manual says that additional vehicles will be detected automatically, and I have tried various combinations of modifying the config files for the vsm, emulator and service-manager to try and start an additional process to create and access an additional emulator instance, but nothing has worked. Is this possible, and if so, what do I need to do?

I can run on Windows or Ubuntu (but headless-only on Ubuntu, no GUI client, just the server-side UCS).

I will upgrade to a more functional version of UgCS if necessary, though it would be nice for users to be able to fly with multiple emulators to hone their skills.



Views: 327

Replies to This Discussion

Hi, you need to modify 2 files

- emulator.propertiers (located in UgCS\server\emulator of UgCS installation directory) 

- vsm-emulator.conf (located in UgCS\bin)

I attached samples of files for 50 copters. We use them for Drone Dance Controller tests.

Do not forget to restart UgCS after config files modification.


.. this will work even with UgCS Open.

Thanks Alexey. I have saved your files to the relevant directories, and restarted, but UGCS won't load the vehicles correctly - see attached screenshot. I have reinstalled from scratch, including deleting User and App Data on Win 10, but the problem persists.

I have attached the relevant log files. Any idea what is going on? The vsm-emulator.log file is empty




service manager log attached.


Hi Stevod,

I'm very sorry, I attached config files for UgCS 2.12 which is under development

For UgCS 2.11 please use attached files


And please note that they are from my home Windows computer, you may need to correct these parameters in vsm-emulator.conf


Hi Alexey,

I'm trying to do the same task. At this point, I'm able to add only one EMU copter and 1 plane.

I tried making changes to my EMU properties file.

But UGCS gives me an error now when I try to start.

I even tried replacing the file with the one you attached in this thread.

Can you give me some directions on how to fix this? 

Thank you,


could you post text of error message, screenshot, etc?

What version of UgCS do you use?

Hi Alexey,

I don't have a screenshot of the error now. I replaced the file with the one you attached.

I'm using 2.11.150

Even with the new emulator properties file, with 50 drones defined, I'm able to add only 1 copter and 1 plane.

I'm using the Open version as of now. Is there a restriction in that version? I would think that is not the case.

You replaced both files? emulator.properties and vsm-emulator.conf?

UgCS Open does not have restriction on number of drones.
I could not find the vsm-emulator.conf file. Can you please tell me where I can find it? In my computer, the emulator folder has the properties file, a zip file and another text file. But not the vsm file.
In UgCS\bin


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service