After more than two hundred flights with my APM2 equipped quad, today, in the remotest of possible locations my quad failed to respond and attempted to fly away by itself! All I can say is thank goodness for Knobthorn trees.

I wanted to get some video of the area but didn't have my small cam with me so I attached my Galaxy Smartphone to the front of the quad, I have done this before and know that the video won't be that great (lots of jello) but will at least give an idea of the scenery. I waited for satellite lock and then hand launched (too much dust on the ground) just in front of where I was standing, I went slowly up to about 20m, hoverered then did a 180deg pirouette and slowly started descending back towards my position.

When the quad was about 3m from me and 2m off the ground I throttled up to stop the descent which was fine but now the quad was drifting forward slowly so I tried to tilt it backwards... suddenly I had that sickening realization that it wasn't responding, I wiggled the sticks...NOTHING!. I ran towards it but it was still drifting forward and climbing very slowly, now at about 2.5m. It continued very calmly and smoothly and I briefly considered throwing the only thing in hand (my transmitter) at it to try bring it down, but it flew on until it collided with a Knobthron tree at about 4m high.

3 motors were jammed by branches but one was still spinning away calmly. I wasn't... I was able to run to the nearby parked pickup and drive under the tree, reach up to unplug the battery and then get the quad down.

I have read the horror stories of fly-aways but one naturally never expects it to 'happen to me'.

- My radio is a tried and tested two year old Hitec Aurora 9 which has one of the most robust AFHSS 2.4GHz systems. The quad was 3m from me when it happened!

- My failsafe is setup correctly and double-tested, with the throttle channel going to 900ms on event of signal loss.

- All four my SS 30A ESC's (2A BEC) power the APM2 (each tested 0.09v of each other) effectively quadrupling the current capacity. I've never had a suggestion of a brownout.

So what happened? I don't know, I can't see anything definative in the logs (attached). If someone has any ideas I'd be very grateful!

As for now my faith in APM2 has been shattered, like an old friend you can no longer trust.

Views: 4341

Attachments:

Reply to This

Replies to This Discussion

I also tried putting the radio Tx inside a metal box about 20m away and held the phone on top of the Rx and APM, turned Airplane mode on and off on the phone and even took some video while doing that. CANNOT get the PWM's to flat line like in the crash log.

I reckon it was aliens :)

I should've known, you at Crooks Corner (CC), yes!

Here is the onboard video of the fly-away and crash, excuse the extreme jello from the phones CMOS sensor at times, there was no attempt to insulate the phone from the frame:

Have you found a issue about this lockout?

Interesting that it occurred when you passed just behind the trunk of the tree.. you say you were 3m away though?

At the time of the lockout there was nothing between me and the quad, as the text appears in the vid I'm standing about 3m to the left of the quad, the quad is looking forward and the Fever Tree with the greenish bark is directly ahead.

In the crash log the four PWM traces (ail, ele, thr & rud) go absolutely flat, I cannot reproduce that now in literally hours of testing.

Why is it with MPv1.2.19 I can no longer find Roll IN, Pitch IN, Yaw IN & Thr IN as below?

Ok good, it's not just me, I thought I just couldn't find it them the selction list.

It's working fine for me...are you guys looking in the dataflash log's ATT message?

By the way, we've been spending a good bit of time on the failsafe code.  There were/are a number of issues that are on their way to being fixed including:

    1. throttle momentarily drops to zero when throttle failsafe is engaged (fixed in trunk)

    2. after a flight, if you turn off your receiver before disarming RTL will be engaged (fixed in trunk - motors will be disarmed)

    3. if the receiver loses power, flight mode will be changed to flight mode 4 instead of RTL (fixed in trunk - flight mode changes are ignored when in failsafe).

 

There's just one last change (that i can think of) which is that we need to check if the ppm encoder has died and initiate a failsafe.  I actually think this is what happened to Graham.  It's almost impossible..but I think it might be the cause.

 

Graham, maybe you want to check what your copter does when you leave all the signal wires plugged in but remove power to the receiver?

Checked that, it just triggers failsafe. Only if all 4 wires are removed simultaneously can I reproduce the PWM flatlines.

It's really encouraging to hear that improvements are to be included in the code.

Just after the incident a random thought that I had was that the one thing that could've changed my outcome (except for the tree) was if the quad was decending gently rather than climbing gently but that presumedly was a result of where the throttle was when the lockout occured and not something in the code?

Re Headings and missing items from Mission Planner Log Browse Michael Oborne says to connect your APM and it will show correctly

You lost me after the first 'the'...:)  (this thing has USB?...)

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service