Hello All! 

I am having trouble connecting my quad copter to mission planner. For whatever reason, my computer wont detect it in the usb ports (however it powers the drone up). 

All the drivers are automatically installed with mission planner.... so I assume I have the correct drivers but maybe I am wrong? 

I'm using the quanum nova fpv : http://www.hobbyking.com/hobbyking/store/__55106__Quanum_Nova_FPV_G...

Yes she has taken a beating but even before the crash I couldn't connect it... all the innards currently seem functional. If anyone can help me connect this I would be forever grateful!



Views: 484

Reply to This

Replies to This Discussion

Hi Alex,

do you see a COM - port in Mission Planner?

Also the baudrate has to be corrct to connect. Its usually 57600kbit/s for APM board.

Both settings are on next to the "CONNECT"-button.


Hi Patrick, 

Thanks for your reply. 

I have checked and I have no COM port in MIssion Planner. I only have Auto, TCP, UDP, UDPCI. I tried all of them with 57600kbit and still no dice. 

Anybody have any ideas as to why I can't connect?



It seems that you haven't a driver installed...

please check your "Device Manager" in your "Control Panel" (assume you've got a Windows-PC)

Then plug or unplug your Quadcopter, you should see refreshing the device list. 

Maybe after you plugged it in you see a "unknown device" or something like that.

When you didn't see any change in your Device Manager, your board or connector could be broken.


Hi patrick - thanks for your help

Unfortunately it seems I cannot connect- device manager will not detect anything. I don't think the connector is broken since it lights up my quad when I plug it in... so perhaps it is my board. Is there any other way to test my flight board condition? 

Unfortunately I don't know the hardware itself. Maybe you can look inside and check visually the connections. 

Probably pictures would help. 

Do you checked it on an other computer? You don't need Mission Planner installed, just open your Device Manager.

What does that mean:

Link to Hobbyking

Maybe the manual is worth to read?


Thanks Patrick! I am going to check it tomorrow when I get to my office! I'll update how this works 


Thanks for your help Patrick! 

Finally managed to connect it....

basically It won't connect via the port on the underside of the copter... it needs to connect directly into the board inside the shell... which makes for an inconvenience once I put it back together

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service