I've read many threads these past days and before giving up I'll give it another shot...

Here's the deal- I bought the Neo-6m from HK, connected to the Crius board and got NO GPS.Trying to investigate this, I bought an FTDI board , connected to U-Center via USB (attached photo 2) and I get no satellite signal.

Additional info:

Windows 7 X64, newest driver installed.

U-Center: Changed every conceivable baudrate and tried various settings according to other posts (attached photo 1), green connection link at the top but grey in the communication status bar, tried to upload config file- timeout error.

Solid red LED on GPS, when changing rate TP (Timepulse) blinked according to new interval- weird, huh?

Excluded possible wiring disconnection by adding a new set (disregard the colors for a moment) switched Rx and Tx to eliminate "confusion" factor, no go.

Do these findings lead to the conclusion that this a GPS failure and needs to be replaced? Or there's something else I need to check?

Your comments would be greatly appreciated.



Views: 8672


Reply to This

Replies to This Discussion

It sounds like you should be sending it back to HK. The board is not supported here but somebody might know your answer.

Thank you, Gary.

Double check your wiring.

Also is the ftdi board 3.3V or 5V ?

I have one ftdi cable that connects ok and can read config settings from eeprom, but writing timeouts everytime. Still mystery to me, but i changed another ftdi board and it worked ok.

Have tested your ftdi board that its ok for example this way? :


Regards Jani

Thanks Jani for your reply. I'll give it a world, but, the comm failure is both to the PC and flight controller with different sets of wires, so I'm guessing there won't be much surprise in testing the FTDI. Get back to you when I'm done.

I have a NEO-6M running on a CRIUS AIOP. Something is weird where the GPS seems to keep the whole system from booting up. if I unplug the GPS it will boot up fine. Maybe there's still a loose or intermittent connection, but I have my suspicions about the battery on the GPS board. I'm going to try replacing it. It's weird how it always seems to boot up eventually when I hit the reset button just the way it wants me to, but seems to change it's mind how it wants me to. If the battery change doesn't solve it I'm just going to solder the rest of the serial data lines and do away with the Dupont connectors. Saving up for the APM 2.5 or 6, if for no other reason the more graceful cabling.

Sounds power or wrong wiring problem? You have correct wiring between APM and GPS and GPS red light goes on after power up?

Regards Jani 

On the CRIUS I need to connect bare ends from the connecter attached to the GPS to the bare ends going into Serial2? on the AIOP. I had started with a Dupont connecter, but I ended up soldering each connection after the perceived loose connection issue.

 This morning I got instant boot up and 3D Fix on first power up without resetting. Later on I was having trouble again. I'm now thinking it might be working correctly with a realy fresh LiPo (I'm tapping power from the main battery through a UBEC to power the board. This keeps the board power and the servo output rails isolated) but having issues once it's run down a bit. I had been using a second 2 cell Lipo to power the board, but those batteries are in NJ and I'm in CA this week. I might try to pick one up out here.

Solved it. My UBEC wasn't supplying enough power. The GPS wasn't the problem but the tipping point where the whole system browned out. I discovered this by connecting the board to the laptop with the USB cable. Booted right up . . . but the LED's seemed brighter too! I put plugs on a brand new UBEC and plugged it in. All is well.

Hi Don,

Thanks for your posts and I'm glad it worked out for you. I have tried the connecting the GPS to the laptop with USB and FTDI board, to no avail. Upon contacting HK regarding this issue, I have been getting very sketchy answers about how they are going to deal with it. All I get is "we're working on it". I'll hope for the best and plan for the worst.

Did you get your CRIUS board from Hobby King as well? They had a problem with the voltage regulator on the boards they had made. They released a "Version 2" that fixed the problem. I'm trying to remember specifically what the issue was, but I think it was a 3.3/5v, possibly that it was only supplying 3.3 unless you bridged a pad to a resistor . . . Not sure it's even relevant to your issue. I got mine from RC Timer and from most of the forums people seem happy with RC Timer's stuff while Hobby King can be hit or miss.


I have the V. 2 board, but as I mentioned the GPS has been receiving power (the LED came on), and the U-Center was able to initialize a connection (but no data), so that wasn't the issue. Last night I finally got an answer from HK stating that the GPS module is faulty and offered a refund. I'm thinking about getting the LEA-6H.

Ive got the same Issue, I only get a GPS lock on USB, and not on 3S battery. Ive left it on battery for 30mins and no lock, just flashes. Connect it to USB and in under 60 seconds i have a 3d fix.

This has happened with 2 GPS units now

Any ideas?


Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service