I've read many threads these past days and before giving up I'll give it another shot...

Here's the deal- I bought the Neo-6m from HK, connected to the Crius board and got NO GPS.Trying to investigate this, I bought an FTDI board , connected to U-Center via USB (attached photo 2) and I get no satellite signal.

Additional info:

Windows 7 X64, newest driver installed.

U-Center: Changed every conceivable baudrate and tried various settings according to other posts (attached photo 1), green connection link at the top but grey in the communication status bar, tried to upload config file- timeout error.

Solid red LED on GPS, when changing rate TP (Timepulse) blinked according to new interval- weird, huh?

Excluded possible wiring disconnection by adding a new set (disregard the colors for a moment) switched Rx and Tx to eliminate "confusion" factor, no go.

Do these findings lead to the conclusion that this a GPS failure and needs to be replaced? Or there's something else I need to check?

Your comments would be greatly appreciated.



Views: 8653


Reply to This

Replies to This Discussion


I have another issue with the CRIUS board, maybe you could help: if I connect the battery, the board flashes twice but does not boot (both UBEC or ESC power), however if I connect the USB first then it boots and stays on after connecting the bat. Any ideas?


Hi Dean,

my issue was a bit different, the GPS didn't provide any data, whether by USB or bat. However, it sounds like a wiring issue. What type of board and GPS do you have?

Thanks Gabby,

Ive tried a GPS unit from hobby king the uBlox NEO-6M, ive tried 2 different APM boards and the stock 3DR GPS unit, a uBlox aswell to no avail

Im really stuck, any ideas?



I'm only speculating here so please excuse me... When I tried to work the problem I tried to eliminate the smallest details that may be overlooked, like wires, for example. Bad wiring may cause this issue (perhaps you're using one set for the bat option but a different, good set for the USB?). Also, on some boards (like CRIUS) the power from the ESC will not go tho the GPS unless a UBEC connected and power-routing pin is removed.

That's about what it was doing for me. There were two orange RX/TX LED's by the USB connector that would alternately flash and the red LED would flash a few times and that was about all that would happen.

 The "manuals" I've found all use confusing wording around that yellow jumper and what's really going on with it. Really, I think it should be off no matter what. If you wanted to use on of the ESC's to power the board, use a servo y cable, but I really thing a separate UBEC is the way to go. I was salvaging an old speed controller for it's UBEC and that was probably a bad choice. I'm now using a brand new UBEC.

I always had a green light on my GPS and telemetry module, but I don't know how much of a "ready light" indicator those are. Like, they know they have power, but not if they have enough power.

I was able to boot by unplugging the GPS on power up and then plugging it in once it was running. I have everything mounted in a 97 cent soap box from Walmart, velroed to my tricopter . . . so that was a little frustrating as an operating proceedure.

Try a different UBEC . . . preferrably 5 amp

Thanks Don,

See, that's the thing, I have it connected to a 5 amp UBEC and the jumper is off. I thought that the UBEC would solve it but I got the same results. Thanks anyway, I'll keep looking.

I'm feeling like I want to start looking at the code (not like I feel like I'm going to understand it very well) to see what it's trying to do on bootup. It seems like there's some sort of hiccup going on here that's more of an issue in a low power situation. I had one more occurrence of not wanting to boot up for no apparent reason and it's been fine again ever since. Also, my last flight didn't seem like it was self leveling in stabilize mode.

OK, so maybe it was a coincidence that it started working when I switched to a new UBEC. Today it wouldn't boot and I took a look at the board since I had been flying in a dusty/leafy spot yesterday. I brushed off what I thought was a clump of dirt. It turned out to be what was left of one of the two surface mount components (capacitors?) under where it says "CRIUS" on the board. Assuming my board was bricked I headed home (from the mountains above Santa Barbara) leaving my wiring harness for the GPS and Telemetry on the rock I was setting up on. When I got home I scraped off the rest of the crumbled component and powered it up to see what it did. Booted right up. 30 mile round trip later to get the cable off the mountain I have GPS lock and it seems ready to go. I think it may have been flopping loose on the board and shorting out something else. Now that it's gone it seems fine without it. Anyone have schematics for the CRIUS? Not like I could ever solder another device that small to the board . . .

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service