I was setting up my new airplane with me new APM2 and noticed that I had a very unsteady display on the Mission Planner. The artificial horizon and other parameters were jumping around a little. This was with both USB and telemetry connection.


I had the GPS mounted on top of the APM2. I found that if I unplugged the GPS that everything was steady. I hooked up my old Media Tech GPS and all was well. Has anyone else had this problem?


Next order I will have to get a longer GPS cable and relocate the new GPS to see if that solves the problem. The problem is that the new 3DR/uBlox GPS very HUGE and it’s not easy to find room for it.



Views: 4888

Reply to This

Replies to This Discussion

Do you have a FPV setup? If you do, how close is the lines and gps module to the video transmitter?


Do you think it is making RF noise or noise over the connection wires? Will moving it farther away make any difference or is buying a longer cable a waist of money? Has anyone tried this?

Most devices make RF noise. I make sure mines away from receiver and video transmitter. Also battery lines can ESC and battery lines can cause magnetic affect and throw off the gps. I seen that problem happen alot on the gps mounted APM2.0.

May be there is a reason why the DJI Controllers have a mount for their GPS modules that takes it a bit away from IMU and Processor? I am just ordering one and will make sure I get one with a long cable!

In my tests I extract APM2 to the frame and only has conected APM2 GPS (3DR LEA6) and ESC

Maybe they will redesign the circuit board to provide improved shielding. A nice plastic box would also be good.


My old Media Tek GPS is working excellently so I think that I will just fly that and forget about the new 3DR GPS until they get the bugs worked out. They definitely have some work to do to make it usable for everyone – especially for those with small aircraft.




It depends on each setup. When I was using my onboard gps it was taking 30 to 40 mintues to get a fix and then in flight it would fly off 20 yards of course. The new gps is away from the fpv electronics and I get 10 sats in 1 min. I also disabled the onboard gps by adding the blob to the onboard.

Just going on a limb here, but how sure are you the new GPS is "the problem". In other words, 99.9% of issues where people say they cannot get the GPS to work or have issues, it's the BEC, ESC, or other load such as servos generating noise on both power and ground throughout the system.

I can pull out the trusty o-scope tonight and look at the new GPS since I have one but seriously doubt it's generating RF or EMI of significant level.

What is far more likely is that the power or ground wire noise between the APM and the GPS was acting like an antenna and radiating the noise actually generated from your power source. It might be luck that the MT is either shunting that noise, or just moving stuff around (since they are different sized boards) was enough to make a difference.

I'm just saying that's a pretty bold statement to say the new GPS is flawed and generates interference. Without some actual testing with o-scopes and RF equipement, your blind swap test only proves there is something in your system (wires, placement,and power scheme) causing a problem.


Nothing wrong with bringing the issue to the forum, but i'm just saying let's do some testing (besides just swapping the MT back in) before using the "jump to conclusions mat".

I have a separate BEC that only runs the receiver and APM at 5v. The servos have a separate 6v supply. That was the first thing I thought of also. I measured the voltage and it was 5v. I also tried adding a large filter capacitor to APM power and that made no difference.

With everything exactly if I switch back to the Media Tek GPS everything is steady. So if everything else is exactly the same then it has to be the GPS.

I am not saying that it’s flawed. I actually did a couple of flights and it works but with all the noise on some parameters it’s probably degrading performance. I’m sure that they are working on it and will come up with a solution.


I noticed the same thing and the problem is caused by the increased sensitivity of the new gps. The AHRS code in version 2.50 uses the gps velocity in calculating accelerations for x/y drift control. GPS gets velocity information from slight doppler shift of the carrier signal. When you are indoors you are getting multipath reflections that are messing with the velocity readings and thus causing jitter in the ahrs display. Take the unit outside away from walls and see if the jittering stops. The only thing wrong with the new ublox is that it's antenna is too sensetive.

Now that’s an explanation that I like. Perhaps just a little more firmware filtering and everything will be perfect. I will have to see if it’s any smoother when I fly out in the country at altitude.

I am doing some modifications to my airplane so it will be a while before I can test that.


Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service