Hello,

 

Just down loaded the new CODE, removed the "//" for the gps and tried to compile the code for the APM and got this screen:

 

 


This mesage came up in the red box at the bottom of the page:

 

ArduPilotMega.cpp:20:77: error: AP_ADC.h: No such file or directory
ArduPilotMega:79: error: 'AP_ADC_ADS7844' does not name a type
ArduPilotMega.cpp: In function 'void Read_adc_raw()':
DCM:36: error: 'adc' was not declared in this scope
ArduPilotMega.cpp: In function 'void read_airspeed()':
sensors:54: error: 'adc' was not declared in this scope
ArduPilotMega.cpp: In function 'void zero_airspeed()':
setup:22: error: 'adc' was not declared in this scope
ArduPilotMega.cpp: In function 'void init_ardupilot()':
system:128: error: 'adc' was not declared in this scope
ArduPilotMega.cpp: In function 'int8_t test_adc(uint8_t, const Menu::arg*)':
test:192: error: 'adc' was not declared in this scope
ArduPilotMega.cpp: In function 'int8_t test_gyro(uint8_t, const Menu::arg*)':
test:287: error: 'adc' was not declared in this scope

 

I have no idea what this means, can someone please help or point me in the direction of understanding the above issue please?  Thank you.

 

Regards

 

Martin.

Views: 860

Reply to This

Replies to This Discussion

First things first go to preferences and select the APM code folder as your sketchbook not your sketchbook folder. This is the cause for many problems and plus its always good to check

Hello Ritchie,

 

Thank you for your help! I think I understand your point & believe that I might have tried both ways already:

 

I have this "C:\Users\Martin\Desktop\AUTO pilot\NEW APM 13 12 10\ArduPilotMega 1.0" set in the Preferences, this allows the use of the file > sketchbook > ArduMegaPilot in the Arduino IDE. The code will load but not compile.

 

If I use "C:\Users\Martin\Desktop\AUTO pilot\NEW APM 13 12 10\ArduPilotMega 1.0\ArduPilotMega" set in Preferences this will not show the ArduMegaPilot files in the file > sketchbook in the Arduino IDE. There is just a small box at the side of the menu (I've added a picture to show).

 

Regards,

 

Martin.

 

I've seen that before. As they said, get rid of all of the sub-folders. Put APM right in the sketchbook folder.

Thank you all for your advice on this issue,

I have moved the APM file to the desktop and used: C:\Users\Martin\Desktop\ArduPilotMega 1.0 in preferences in the IDE.

I have left the libraries and APM folders separate in the main folder and now the code will compile! I have no idea why this should be the case, however they work just fine now, and that is what counts in my book!

Thank you all for your help :)

Regards

Martin

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service