I just noticed this at the Chinese on-line retailer, ThanksBuyer.com

They are pricing the bundled versions attractively.  Obviously made to compete against the APM micro 3.1

Flight controller

FC bundled with power supply

FC, power supply, GPS unit

If anyone makes the leap, perhaps you could keep us informed on your experiences.

Happy flying all!!

Views: 30623

Reply to This

Replies to This Discussion

Having retired the CX-20, I rebuilt using a FLIPFPV frame, mini APM Pro FC, and Turnigy 9x. I've had a few successful flights prior to upgrading from the Cheerson radio transmitter to the Turnigy. Now that the Turnigy has been connected, the FC preflight checks. What's weird is that when it's plugged into the Mission Planner, it passes all checks, arms, performs motor/compass calibration and everything. When unplugged from the computer, I get a FAILSAFE message and can't arm it.

The lights on the APM are solid green and blue/purple flashing.

GPS (Neo-7N) has solid green and blue flashing, which I believe indicates power and GPS lock.

Recap: Why can I arm, connect and control while plugged in to Mission Planner and not while unplugged?

**Side Note** I after I typed that, I wondered if it would allow me to connect even if I wasn't connected to Mission Planner. So I disconnected MP, plugged in the USB, plugged in the battery, and it worked. Now I'm wondering if it's some kind of power issue.

When plugged into USB the battery fail safe is disabled. "I get a FAILSAFE message and can't arm it." check you fail safe setup. Copter.ardupilot.com has the instructions

Thanks Bill. I had the Batt_Volt_Pin set wrong in the parameters. After changing that to 13 (for APM) it allowed me to arm. However, when I tried to fly, it was very sporadic with no control over it. Fortunately, after flipping the switch to Acro mode, I was able to get the motors to stop turning and bring it down in a safe location. Obviously something is a muck in my settings. 

So it seems that I still have an issue that I can't put a finger on. When plugged in to the computer, the copter flies fine. When unplugged, there seems to be a bit of a delay in my throttle response and then, BANG! It just takes off uncontrolled / uncontrollable. Anyone deal with anything like this?

Radio Failsafe and PPM Encoder.  We have integrated hundreds of these in Quad and Hexa Copters with great results, One problem we often encounter is with the PPM Encoder not running current firmware. With older firmware the PPM Encoder does not recognize PWM hold  as lost link and trigger failsafe. You may need to flash current firmware if you are using transmitters such as FlySky Th-9X.

Has anyone gotten a telemetry radio connected?  I have an RFD900, connected pin's: GND, VCC, RX, TX to the top 4 pin's under the telemetry label but won't connect.  can't find where to connect the CTS or RTS pins..

Depending on where you purchased your Mini APM Pro, the pins on the dupont connector might not be correct. Check the pins coming from the radio to the dupont connector. If you made the cable yourself, check that you did not reverse the RX and TX. Check that you have TX on the outside, then RX, VCC, GND. Your radio should light up with sold green when you plug into to the Mini APM Pro and provide power to the Mini APM Pro. We use these in the DaVinci Challenge. Once in a while we find a bad cable or connector. Get a few extra cables.

Took to case apart and seen on the PCB that I do have the correct pin/s connected..

Reading from left to right on the top row of the APM Pro:

TX, RX, 5V, GND

On my RFD900 (jumper on 4 & 6)

Pin 1: GRD

Pin 3: <BLANK>

Pin 5: 5V

Pin 7: RX

Pin 9: TX

I took a known working RFD900 out of my Plane and connected it up, same thing..  I get a link light and also flash red when communicating.. Just won't communicate with the APM.. ugh

If you have solid light on your RFD900, your Ground and 5V connections are correct. You may have your RX and TX reversed. Take a close look at the red light when you attempt to connect to your Mini APM Pro. If the flashing becomes rapid, then you have the RX and TX correct. If the flashing stays the same (slow), then you may have RX and TX reversed. 

If you have much experience with telemetry radios, you know the most common problems are (1) bad or incorrect cable; (2) fault with Flight Controller: and (3) fault with Mission Planner. Is Mission Planner saying "No Heartbeat Received?" If so, the problem is likely with the cable or Flight Controller. If you are confident the cable is correct, try loading new firmware on the Mini APM Pro. 

 

Well..  odd.. but I guess it makes sense..  I had to switch the RX & TX on the modem..  to TX is going to RX on the APM and RX going to TX on the APM..  it works!

Great! The Mini APM Pro is a big upgrade from the APM 2.8. It also provides a simple path for upgrading to the PixMini. One thing to watch for is the PPM encoder. The Mini APM Pro ships with an old encoder. You should update the firmware on the encoder. 

I've been following this thread with interest.  I was looking at picking up an APM 2.6 to trial in a Bix3 but like the smaller form factor of the APM Pro. Would those who are using them say that there are no disadvantages to using this over the 2.6?

Can anyone recommend any good sources for the APM Pro that they trust?

We're not needing the Pixhawk at this point although, if there was a cheaper clone you could recommend, we might consider it.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service