I just noticed this at the Chinese on-line retailer, ThanksBuyer.com

They are pricing the bundled versions attractively.  Obviously made to compete against the APM micro 3.1

Flight controller

FC bundled with power supply

FC, power supply, GPS unit

If anyone makes the leap, perhaps you could keep us informed on your experiences.

Happy flying all!!

Views: 30792

Reply to This

Replies to This Discussion

The APM Mini Pro is similar to an APM 2.6. You connect the sik radio to the telemetry port and multiplex into the OSD. 

I've plugged the radio into the telemetry port and I've plugged the osd into the uart0 port. But neither radio or the osd work. The radio shows a solid green light when on and the radio plugged into the computer show solid green as well. The radios will not form a connection for mission planner or Tower to work. The osd just shows "no mav data" on the screen. What do you mean by plug the multiplex into the osd? Thanks
Also both radios show up properly in the mission planner sik radio page. They are both configured the same and have the same net Id.

Start with just the telemetry radio. Plug the dupont connector into the Mini APM Pro telemetry port. A green light should stay on when it connects to the ground radio, and a red light should start blinking when it connects to the flight controller. If this does not work, send me a photo. Mini APM Pro kits come with a variety of types of telemetry radios. Some work better than others. It the telemetry radio works, you will need to use a Y cable to connect the OSD into the same port. There is only one telemetry port on the Mini APM Pro.

The OSD and radio plug into the same port directly above the GPS and compass ports. Just make sure your ground goes to the far middle then positive Rx, Tx. I'll add a pic. If having trouble getting communication and you have drivers installed, showing on MPlanner then swap a Tx to Rx on the APM pro. And as Ronald said use a y cable.
Here's the pin config.
Attachments:

is there something I need to do to enable the apm to send the telemetry data.  The radios solid green light come on and the both connect under the sik radio tab, but mission planner won't connect to the apm through the radios.

You shouldn't no. I just made up a y harness for an old APM pro I had earlier loaded a quadcopter onto and at first the green lights came on which I then went to the DuPont plug swapped the yellow and green cable around, Tx Rx, and wallah, pushed connect and it connected. So give that a go, it sounds like that's your issue because the radios are already powering up and they will show up on mp. Just try that and message back.

So I Tried starting with just the radio plugged in and no osd.  The radio had the solid green light on but would not connect to MP. I then tried only the osd plugged in and it worked and show the relevant items on the screen.  So knowing that the port is working, I tried a different radio that I had instead of the one that came in the apm package and it worked. I was able to connect to MP through the radios.  So I made the y cable and everything is working like it should.  What confused me at first is looking at the attached image from the thanks buyer manual, is that it shows the osd plugged into the UART0 port instead of using a cable to the telemetry port.  thanks for all the help guys I appreciate it.

Attachments:

Hi everyboady can you help me please?.. I got a APM Pro clone and a BN880GPS but I got a bad compass health and i cant calibrate it.. When I disable MAG, bad compass health disapears but I still got a Compass1 99 error and no calibtration and weirdly I can see on the panel my heading moving... Even when I disable all compass parameters.. I think this APM based on APM 2.6 has a mag in but to use a external compass you might disable something on the board or do something I think.. I tried all that I found and spent a lot of time on the web to find solution but no way... Test the SCL, SDA wires has a 3.2v with GND... Here is my APM Pro

Attachments:

Luke, I'm just installing an old APM mini 3.2, I don't know yours, but mine I had to disable int compass cutting something that disable it in the board

What is the APM Mini 3.2?.. I only know mine (apm pro), apm 2.5, apm 2.6, apm 2.7, apm 2.8, apm 3.1.
Can you show what you cut to see if I got this on my board?..

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service