I just noticed this at the Chinese on-line retailer, ThanksBuyer.com

They are pricing the bundled versions attractively.  Obviously made to compete against the APM micro 3.1

Flight controller

FC bundled with power supply

FC, power supply, GPS unit

If anyone makes the leap, perhaps you could keep us informed on your experiences.

Happy flying all!!

Views: 30394

Reply to This

Replies to This Discussion

Something else I noticed was that the Pitch lever (Mode 2) is reflected in the opposite direction on MP. When I push the stick up, the green bar moves down and vice-versa. 

I do like you... I bought a Pixhawk and now no problems.. I got two compasses now.. Which might I use for primary compass?... Internal or external... I got a BN880 with a HMC5883L.

Ronald Pandolfi said:

The APM series (2.5, 2.6, 2.7, & 2.8) all use the 8bit processor. They were made in several form factors with a variety of cable connects. All will work with Mission Planner, APM Planner, Tower, and other open source Ground Control Systems that communicate over the same protocol.The 2.7 and 2.8 have substantial improvements over the 2.5 and 2.6. 

Quick answer to your question is to use the external compass as primary. Be sure to check that mission planner compass heading matches true magnetic heading for several orientations. Also performance depends on which version Pixhawk you now have. The current version is 2.4.8. The 2.4.8 is significantly better than the old 3dr Pixhawk in several respects including the connectors. The 2.4.8 has picoblade connectors whereas the old 3dr version hirose connectors. We prefer the Mini Pixhawk (Pixmini) with dupont connectors. The new Pixracer has many more improvements including better connectors. As you can tell from my response, connectors are very important as are quality of cables. 

Ok, so I thought that maybe part of my problem was the props. Since I bored out the hubs to 8mm so they fit on the motors, I'm sure they weren't very balanced. Today I put the dji carbon fiber blades on, that are balanced, and put a 3300 mAh 35C battery on (reducing the weight to 1425g). However, it still went no where. It's almost like the #3 motor (top left) wasn't responding very well. At full throttle, it just sat there. I moved the sticks pitch and roll and got nothing. There was a little more movement pushing the stick to the left, but hardly any difference pushing them to the right.

It just seems crazy to think that the APM Pro is the cause of all this. Can someone examine these logs and tell me what needs to change?

Attachments:


Hi Ron G....It is a good idea to let people know your level of experience. Assuming you have not been flying multirotors for long, it sounds like you may have a problem with an ECS or power connector. Run a motor spin test and verify that all motors turn in the correct direction and that they all begin spinning at the same throttle setting. I like to see all motors begin spinning at a throttle setting of about 6. Then check that they are all spinning at about the same speed at a low throttle setting of about 15. If they do not, perform an ESC calibration. If you do have one bad motor, the problem is likely with one of your power connectors to the ESC. Try swapping one of the ESCs to the bad motor and see if the problem shifts to another motor with the ESC or if it stays with the motor.


Ron G said:

Ok, so I thought that maybe part of my problem was the props. Since I bored out the hubs to 8mm so they fit on the motors, I'm sure they weren't very balanced. Today I put the dji carbon fiber blades on, that are balanced, and put a 3300 mAh 35C battery on (reducing the weight to 1425g). However, it still went no where. It's almost like the #3 motor (top left) wasn't responding very well. At full throttle, it just sat there. I moved the sticks pitch and roll and got nothing. There was a little more movement pushing the stick to the left, but hardly any difference pushing them to the right.

It just seems crazy to think that the APM Pro is the cause of all this. Can someone examine these logs and tell me what needs to change?

I kind of thought the same, since my number 3 motor did not start to spin when the others did. I'm think it's that ESC since I swapped motors and it seemed to do the same on that arm. I've only been building & flying these for about 1 1/2 years, so not quite a newb, but not far from it. I calibrated the ESCs manually and the motors with MP and they seemed to work well then. I seem to remember having a similar problem on the last build I did with that board, which I believe was why I retired it in the first place. But I'm going to try the new ESCs and see if that does the trick. The next step after that is replacing the board with an Ardupilot 2.8.  Thanks. 

Ronald Pandolfi said:


Hi Ron G....It is a good idea to let people know your level of experience. Assuming you have not been flying multirotors for long, it sounds like you may have a problem with an ECS or power connector. Run a motor spin test and verify that all motors turn in the correct direction and that they all begin spinning at the same throttle setting. I like to see all motors begin spinning at a throttle setting of about 6. Then check that they are all spinning at about the same speed at a low throttle setting of about 15. If they do not, perform an ESC calibration. If you do have one bad motor, the problem is likely with one of your power connectors to the ESC. Try swapping one of the ESCs to the bad motor and see if the problem shifts to another motor with the ESC or if it stays with the motor.


Ron G said:

Ok, so I thought that maybe part of my problem was the props. Since I bored out the hubs to 8mm so they fit on the motors, I'm sure they weren't very balanced. Today I put the dji carbon fiber blades on, that are balanced, and put a 3300 mAh 35C battery on (reducing the weight to 1425g). However, it still went no where. It's almost like the #3 motor (top left) wasn't responding very well. At full throttle, it just sat there. I moved the sticks pitch and roll and got nothing. There was a little more movement pushing the stick to the left, but hardly any difference pushing them to the right.

It just seems crazy to think that the APM Pro is the cause of all this. Can someone examine these logs and tell me what needs to change?

If you have good ESCs, you can plug in a USB linker and update firmware and calibrate. If not, you can calibrate via Mission Planner. If the problem persists, clean the bullet connectors with hot water and soap. They sometimes have an insulating coating from rice soup used by the Chinese in the factory for food. They seem to eat and then solder at the same time. If all else fails, upgrade to a better ESC. It is a good idea to keep an extra ESC and motor on hand for diagnostics and repair. You can learn more via our website: www.KashmirWorldFoundation.org

Thanks!!... That a super drone and multirotor forum!!..

Ronald Pandolfi said:

Quick answer to your question is to use the external compass as primary. Be sure to check that mission planner compass heading matches true magnetic heading for several orientations. Also performance depends on which version Pixhawk you now have. The current version is 2.4.8. The 2.4.8 is significantly better than the old 3dr Pixhawk in several respects including the connectors. The 2.4.8 has picoblade connectors whereas the old 3dr version hirose connectors. We prefer the Mini Pixhawk (Pixmini) with dupont connectors. The new Pixracer has many more improvements including better connectors. As you can tell from my response, connectors are very important as are quality of cables. 

Hello everybody!

I would like to use the stabilization provided by Mini Apm Pro for a servo gimbal. Which pins can I use? Which settings I have to do in Mission Planner?

Thank you!

I have been looking around for an answer and have tried a few things I found online with no luck.I am using a Frsky XSR in cppm mode with the Apm Pro and I can only get the first four channels working in the radio calibration.None of the switches seem to work or show up as working in Mission Planner.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service