Hi,

I got my new ArduPilot Mega board this week and it has already the Atmega 2560 on it.

 

So how do I get the ArduCopter RC2 code on that board ?

 

I already selected the right board type

 

 

 

 

 

 

This is the error message Ill get when I try to upload the code:

D:\DATA\Arduino\libraries\APM_RC\APM_RC.cpp:27:3: error: #error Please check the Tools/Board menu to ensure you have selected Arduino Mega as your target.

Please help!

regards,

Peter

Views: 2695

Reply to This

Replies to This Discussion

But the IMU board is unchanged. I'm not sure what this has to do with possible issues with the new APM board. 

 

BTW, the Configurator will soon be retired, as it's not longer necessary thanks to the CLI and the forthcoming GUI utility in the Mission Planner. You don't need it now, so it's not a high priority to fix any issues it may have with new hardware. That said, I'm still not sure what the issue might be here.

Chris, I know that the configurator will be obsolete, and it´s just a avocation while I am waiting for the ArduCopter Mega release :-) I have installed and tried the Mission Planner, this is really a awesome piece of software. GREAT work ! 

 

Peter

Hi all, I just managed to find a workaround get connected with the Configurator to the IMU Shield.

Hardware:

Ardupilot Mega v1.4 2560

ArduPilotMega IMU Shield/OilPan Rev-H

The problem is that the board is not coming out of reset status as log the Configurator is polling (RX Led is flashing) for connection.


Solution:

You open the Configurator select the correct COM port, Baud Rate 115200 and Timeout 30s

To get the connection, you press and hold down the RESET button on the IMU Shield than you click on the Connect button at the Configurator and immediately release the RESET button on the IMU Shield. Thats it, the three led´s start flashing and then the green led goes on and you are connected!

 

I hope this helpsfull for everybody having this problem!

 

@Chris

do you know an expected release date for the ArduCopter Mega?

 

Best regards,

Peter

 

Hi, thanks for the solution to the problem:)

 

Krzysztof (Chris)

Hello,

I was able to receive $40 from Sparkfun's free day (Thanks Sparkfun), so I figured I would buy the ArduPilot Mega, but I saw that they only have the mega 1280 for sale. I was just wondering when will the AP Mega 2560 be shipping?

I guess I will wait a little longer.

 

Thanks,

Kyle

I just flashed the ArduPilot Mega build to my board (ArduPilot Mega 2560) and it seems that i am having the same connection problem to ArdupilotMegaPlanner as I had with the ArduCopter RC2 and the connection to the Configurator.

 

If I try to connect the green led on the IMU get dark and the RX led flashes and after 5sec. Ill get the message "Communication Error - no connection" CLI is working perfect.

 

Thank´s in advance,

Peter

Peter, as we've discussed, we do not yet support the APM2560 board--the Mission Planner is not yet compatible with it. Please return yours to be replaced by an APM1280. We'll pay all shipping.  We can send you out the APM1280 board while you're waiting. Just PM me with address details.

 

As best we can tell three APM boards were accidentally sent out with 2560 chips. Anybody who has one can have it replaced for free.

 

We won't be supporting the 2560 for a few more weeks while we update and test software.

Kyle, not for a few more weeks. BTW, we do not recommend waiting for the 2560. It will not do anything that the 1280 does not do, and it will not be compatible with all DIY Drones software. The main reason we're migrating is that it's easier for us to get the 2560 chips, but we will continue to offer both boards and will recommend that most people use the 1280 board for now.

Ok. Thank you Chris for the information. I will be placing my order @ Sparkfun shortly then.

 

Thanks,

Kyle

I'm trying to reload the code onto this board. When I press upload in Arduino, the A B C leds blink quickly for a bit, then the green one becomes solid. Arduino then gives me the error

avrdude: stk500_2_ReceiveMessage(): timeout

 

I can't remember how I got around this before, any thoughts?

 

You're using an ftdi cable connected straight to the 2560 or you have the oilpan mounted and you're connecting with a mini USB?  I'll bet the former.  Maybe try hitting the reset button on the 2560 just after the message comes up which says something like "Uploading 123456 Bytes of 250000"

http://arduino.cc/en/Guide/Troubleshooting#toc1

 

When uploading arduino sketches to some non-standard boards, I've had to manually update the boards.txt file in the Arduino directory to change the programmer to match the one that I'm actually using.  Still, never had this issue with the diydrones boards.  the defaults have always worked for me.

Nope, using the mini USB cable. But your suggestion worked none the less. Thanks!

 

Chris

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service